Интерфейсы, стили 1С 8.x

Как задать различные стили 1С:Предприятия для различных категорий пользователей?

ОсновнойИнтерфейс = ПользователиИнформационнойБазы.ТекущийПользователь().ОсновнойИнтерфейс.Имя; 

Если ОсновнойИнтерфейс = "ИнтерфейсКассира" Тогда 
	ГлавныйСтиль = БиблиотекаСтилей.СтильКассира; 
ИначеЕсли ОсновнойИнтерфейс = "Планирование" Тогда 
	ГлавныйСтиль = БиблиотекаСтилей.СтильПланирования; 
Иначе 
	ГлавныйСтиль = БиблиотекаСтилей.Основной; 
КонецЕсли;          
Есть список имен интерфейсов с пометками. Как сделать помеченные интерфейсы видимыми?

СтрокаИменИнтерфейсов = ""; 

Для Каждого ИмяИнтерфейса из СписокИнтерфесов Цикл 
	Если ИмяИнтерфейса.Пометка Тогда 
		СтрокаИменИнтерфейсов = СтрокаИменИнтерфейсов + ИмяИнтерфейса + ","; 
	КонецЕсли; 
КонецЦикла; 

ГлавныйИнтерфейс.ПереключитьИнтерфейс(СтрокаИменИнтерфейсов);           
Как из формы обработки отключить глобальный обработчик ожиданий?

Процедура ПриНачалеРаботыСистемы() 
	ПодключитьОбработчикОжидания("ПроверкаОпроса", 60); 
КонецПроцедуры 

Процедура ОтказОтОпроса() Экспорт 
	ОтключитьОбработчикОжидания("ПроверкаОпроса"); 
КонецПроцедуры

ОтказОтОпроса();           

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *