Работа со списком значений в 1С 8.x

Как создать список значений?

СозданныйСписок = Новый СписокЗначений;          
Как добавить элементы в список значений?

СписокСотрудников.Добавить(ТекущийСотрудник, ТекущийСотрудник.ФИО, , Фото); 

СписокСотрудников.Вставить(Инд, ТекущийСотрудник, ТекущийСотрудник.ФИО, , Фото);           
Как найти элемент списка значений?

ЭлементСписка = СписокСотрудников.НайтиПоЗначению(ИскомыйСотрудник); 
Если ЭлементСписка <> Неопределено Тогда 
	Сообщить(СписокСотрудников.Индекс(ЭлементСписка)); 
КонецЕсли;          
Как обратиться к элементу списка значений?

ЭлементСписка = СписокСотрудников[Инд]; 

ЭлементСписка = СписокСотрудников.Получить(Инд);

Сотрудник = ЭлементСписка.Значение; 
Представление = ЭлементСписка.Представление; 
Пометка = ЭлементСписка.Пометка; 
Картинка = ЭлементСписка.Картинка;            
Как перебрать элементы списка значений?

Для Каждого ЭлементСписка Из СписокСотрудников Цикл 
	Сообщить(ЭлементСписка.Значение); 
КонецЦикла; 

СтаршийИндекс = СписокСотрудников.Количество() - 1; 
Для Сч = 0 по СтаршийИндекс Цикл 
	Сообщить(СписокСотрудников[Сч].Значение); 
КонецЦикла;          
Как удалить элемент списка значений?

СписокСотрудников.Удалить(0);
Индекс = СписокОбъектов.Количество() - 1; 
Пока Индекс >= 0 Цикл 
	Если ТипЗнч(СписокОбъектов[Индекс].Значение) = Тип("Число") Тогда 
		СписокОбъектов.Удалить(Индекс); 
	КонецЕсли; 
	Индекс = Индекс - 1; 
КонецЦикла;          
Выгрузка данных из таблицы значений в список значений

Рассмотрим случай в необходимости выгрузить из таблицы значений «ТаблицаЦен» выгрузить в таблицу списка для применения в запросе.

КолонкаНоменклатурТаблицыЗначений = ТаблицаЦен.ВыгрузитьКолонку("Номенклатура");
СписокНоменклатур = Новый СписокЗначений;
СписокНоменклатур.ЗагрузитьЗначения(КолонкаНоменклатурТаблицыЗначений);

КолонкаХарактеристикаТаблицыЗначений = ТаблицаЦен.ВыгрузитьКолонку("ХарактеристикаНоменклатуры");
СписокХарактеристика = Новый СписокЗначений;
СписокХарактеристика.ЗагрузитьЗначения(КолонкаХарактеристикаТаблицыЗначений);

Запрос = Новый Запрос;
Запрос.УстановитьПараметр("ТипЦен", СписокТиповЦен);
Запрос.УстановитьПараметр("Номенклатура", СписокНоменклатур);
Запрос.УстановитьПараметр("ХарактеристикаНоменклатуры", СписокХарактеристика);
Запрос.Текст = "ВЫБРАТЬ
| ЦеныНоменклатуры.ТипЦен,
| ЦеныНоменклатуры.Номенклатура,
| ЦеныНоменклатуры.ХарактеристикаНоменклатуры,
| ЦеныНоменклатуры.Цена
|ИЗ
| РегистрСведений.ЦеныНоменклатуры КАК ЦеныНоменклатуры
|ГДЕ
| ЦеныНоменклатуры.ТипЦен В(&ТипЦен)
| И ЦеныНоменклатуры.Номенклатура В(&Номенклатура)
| И ЦеныНоменклатуры.ХарактеристикаНоменклатуры В(&ХарактеристикаНоменклатуры)";
Результат = Запрос.Выполнить().Выбрать();

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *