Условный оператор Если в языке 1С 8.3, 8.2

Автор: | Ноябрь 8, 2019
&НаКлиенте
Процедура ВыполнитьКод(Команда)
 
    /// Как составить оператор Если в 1с 8.3, 8.2
 
    Если 1 > 0 Тогда // Истина
        // блок операторов
        Сообщить("Компьютер выполнит все команды из этого блока.");
        Сообщить("Один больше нуля.");
    КонецЕсли;
 
    Если 1 < 0 Тогда // Ложь
        Сообщить("Один меньше нуля.");
    Иначе
        Сообщить("Сработает именно эта ветка условного оператора (#А).");
        Сообщить("Один больше нуля.");
    КонецЕсли;
 
    Если 1 < 0 Тогда // Ложь
        Сообщить("Один меньше нуля.");
    ИначеЕсли 1 = 0 Тогда // Ложь
        Сообщить("Один равен нулю.");
    Иначе
        Сообщить("Сработает именно эта ветка условного оператора (#Б).");
        Сообщить("Один больше нуля.");
    КонецЕсли;
 
    /// Как составить тернарный оператор ? в 1с 8.3, 8.2
 
    Текст = ?(1 > 2, "Один больше двух.",  "Один не больше двух.");
    Сообщить(Текст); // выведет "Один не больше двух."    
 
КонецПроцедуры
 
/// Скачать и выполнить эти примеры на компьютере

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *