Архив автора: Оля Кузнецова

СКД — вычисляемые поля

Автор: | Октябрь 8, 2019

В конструкторе СКД на закладке «Вычисляемые поля» можно создавать свои вычисляемые поля. Зачем нужны вычисляемые поля, если их можно создавать на уровне запроса? Не все поля можно описать с помощью запроса. Классический пример — использование функций СКД Массив (Array) и СоединитьСтроки (JoinStrings). В колонке вычисляемого поля «Выражение» нужно написать произвольное выражение, которое использует поля компоновки данных,… Читать далее »

Настройка завершения и засыпания сеансов пользователей от версии 8.3.5

Автор: | Сентябрь 18, 2019

В клиент-серверном варианте работы информационной базы, при некорректном завершении работы программы, на сервере могут оставаться не завершенные сеансы пользователей. В старых версиях платформы (до версии 8.3.5) такие сеансы автоматически удалялись через короткий промежуток времени. В новых версиях платформы, время по прошествии которого сеанс уходит в спящий режим и время через которое удаляется сеанс, необходимо настраивать… Читать далее »

Работа с файловой системой в языке 1С 8.3, 8.2 (в примерах)

Автор: | Сентябрь 4, 2019

&НаСервере Процедура ЧтениеИЗаписьФайловНаСервере()       /// Как записать произвольное значение в файл в 1с 8.3, 8.2   // любое сериализуемое (то есть превращаемое // в строку и обратно) значение можно сохранять // в файл, например, массивы, списки значений, строки // структуры и т.д. Числа = Новый Массив; Числа.Добавить(35); Числа.Добавить(67); ЗначениеВФайл(«c:\числа.txt», Числа); // эта функция работает только… Читать далее »

Выбор каталога и его сохранение

Автор: | Август 13, 2019

Процедура КаталогДляПолученияФайловНачалоВыбора(Элемент, СтандартнаяОбработка) СтандартнаяОбработка = Ложь; РежимДиалога = РежимДиалогаВыбораФайла.ВыборКаталога; ДиалогВыбораКаталога = Новый ДиалогВыбораФайла(РежимДиалога); ДиалогВыбораКаталога.МножественныйВыбор = Ложь; ДиалогВыбораКаталога.Заголовок = «Выберите путь для сохранения файлов»; Если ДиалогВыбораКаталога.Выбрать() Тогда КаталогДляПолученияФайлов = ДиалогВыбораКаталога.Каталог; КонецЕсли; КонецПроцедуры

Модальное открытие формы в 1с 8. Как вернуть результат ОткрытьМодально()

Открытие формы модально — форма появляется на экране и блокирует другие окна, пока не будет закрыта. МодФорма = ПолучитьФорму(«ОсновнаяФорма»,ВладелецФормы); Результат = МодФорма.ОткрытьМодально(); Возникает проблема возврата результата, если форма не «для выбора» В описании функции ОткрытьМодально() написано:   Форма.ОткрытьМодально (Form.DoModal) ОткрытьМодально(<Таймаут>) Параметры: <Таймаут> (необязательный) Тип: Число. Время показа формы в секундах, по истечении которого форма будет закрыта… Читать далее »

Функции для работы со строками в запросе

Прямо скажем механизмов для работы со строками в запросах 1С мало. Во-первых, строки можно складывать. Во-вторых, от строки можно взять подстроку. Во-третьих, строки можно сравнивать, в том числе по шаблону. Вот пожалуй и всё, что можно делать со строками. ВЫБРАТЬ «Жизнь прекрасна!» либо реквизит таблицы, у которого тип СТРОКА: ВЫБРАТЬ Наименование ИЗ Справочник.Еда Сложение строк Для… Читать далее »

Принадлежность элемента к группе (ПринадлежитЭлементу)

Определить находиться ли элемент в указанной папке (группе) или нет вместо запроса можно использовать эту функцию Если ОбъектСсылка.ПринадлежитЭлементу(ЭлементСсылка) Тогда Сообщить(«Принадлежит»); КонецЕсли; Пример: Папка = Справочники.Контрагенты.НайтиПоКоду(«00000011»); Если Контрагент.ПринадлежитЭлементу(Папка) Тогда Сообщить(«Принадлежит»); КонецЕсли;

Скопировать таблицу значений 1С (ЗаполнитьЗначенияСвойств)

Для копирования данных из одной таблицы значения в другую в типовых конфигурациях 1с 8 существует процедура модуля ОбщегоНазначения.ЗагрузитьВТаблицуЗначений. Она добавляет в таблицу значений строки из другой таблицы значений, наименования колонок должны совпадать. Процедура ЗагрузитьВТаблицуЗначений(ТаблицаИсточник, ТаблицаПриемник) Экспорт Для каждого СтрокаТаблицыИсточника Из ТаблицаИсточник Цикл СтрокаТаблицыПриемника = ТаблицаПриемник.Добавить(); ЗаполнитьЗначенияСвойств(СтрокаТаблицыПриемника,СтрокаТаблицыИсточника); КонецЦикла; КонецПроцедуры ТаблицаИсточник — таблица значений, откуда берутся значения.… Читать далее »

Тип значения документа, справочника

Для проверки типа документа или справочника В процедуре или функции Если ТипЗнч(Основание) = Тип(«ДокументСсылка.РеализацияТоваровУслуг») Тогда … КонецЕсли; или Если Документ.Ссылка.Метаданные().Имя = «РеализацияТоваровУслуг» Тогда …. КонецЕсли; В запросе выбор когда (Взаиморасчеты.Документ Ссылка Документ.РеализацияТоваровУслуг)