Архив рубрики: ЗАПИСИ ПРОГРАММИСТА 1С

Корректировка поступления и книга продаж в УПП

Автор: | Ноябрь 30, 2020

Не формируются записи в книге продаж по корректировке поступления. Бывает что документ введен верно но регистр НДСЗаписиКнигиПродаж не заполняется. Решение: Воспользоваться обработкой «Проведение по регистрам НДС»

Использование процедуры ЗаполнитьЗначенияСвойств()

Автор: | Октябрь 23, 2020

Процедура ЗаполнитьЗначенияСвойств() позволяет копировать значения свойств объекта-источника в свойства объекта-приемника. ЗаполнитьЗначенияСвойств(Приемник, Источник, СписокСвойств , ИсключаяСвойства);Список свойств и исключения свойств в виде: «Дата, Проведен, ПометкаУдаления»;Приемник и Источник может быть таблицей или объектом методанных

1С 8.x : Поле ввода ~ Маска

Автор: | Сентябрь 25, 2020

Для 1с поле ввода с типом строка можно применить маску ввода. В 1с маска задает формат представления данных и ограничивает вводимой информации. Это очень удобно бывает во многих жизненных задачках, например ввод телефона, ввод специального кода или представления номера. В 1с маску можно задать как интерактивно «в режиме конфигуратора», так и программно. Для 1с поле… Читать далее »

Проверка существования реквизита у объекта метаданных

Автор: | Сентябрь 16, 2020

// Позволяет определить есть ли среди реквизитов шапки Объекта реквизит с переданным именем. Функция ЕстьРеквизитОбъекта(ИмяРеквизита, Объект) Экспорт МетаданныеОбъекта = Объект.Метаданные(); Если МетаданныеОбъекта.Реквизиты.Найти(ИмяРеквизита) = Неопределено Тогда Возврат Ложь; Иначе Возврат Истина; КонецЕсли;  КонецФункции  С давних времен в типовых конфигурациях для этого существовала специальная функция.В конфигурациях последних редакций эта функция стала более универсальной и кроме того стала… Читать далее »

«Неверный реквизит платежного документа КодНазПлатежа». Исправляем обработку КлиентБанк

C 01.06.2020 банки требуют указывать реквизит КодНазПлатежа (код вида дохода) в выписках. При этом его заполнение необязательно. Соответственно в старых версиях обработок «Клиент банк» не загружаются файлы с плат.поручениями. Данная ошибка исправляется очень просто: 1. Открываем конфигуратор и находим нашу обработку «КлиентБанк» в списке объектов конфигурации. 2. Открываем модуль объекта. 3. Находим фрагмент кода: РеквизитыПлДок_НазначениеНеОбязательные= «НазначениеПлатежа1,НазначениеПлатежа2,НазначениеПлатежа3,НазначениеПлатежа4,НазначениеПлатежа5,НазначениеПлатежа6»); и… Читать далее »

Как загрузить шаблон статистики xml в 1С:Бухгалтерия 8 ред.3.0 с сайта Росстата

Загрузим новую форму статистики 12-Ф от 22 — 03 — 2020 загрузим в 1с Бухгалтерию 3.0 Переходим на верхней панели в раздел Настройки Переходим в раздел Отчеты в Росстат — Настройка XML-шаблонов электронных версий отчетов Переходим на сайта Росстата с полным списком актуальных шаблонов Откроется интернет браузер с XML-шаблонами Выбрать нужный шаблон Нажать ссылку Скачать   Загруженный файл необходимо… Читать далее »

Работа с типом Дата в языке 1С 8.3, 8.2

Автор: | Ноябрь 8, 2019

&НаКлиенте Процедура ВыполнитьКод(Команда)       /// Как инициализировать дату константой в 1с 8.3, 8.2   Дата = ‘20130724’; // 24.07.2013       /// Как преобразовать строку в дату в 1с 8.3, 8.2   Дата = Дата(«20130724»); // 24.07.2013       /// Как инициализировать дату отдельными компонентами в 1с 8.3, 8.2   Дата = Дата(2013, 07, 24); // 24.07.2013… Читать далее »

Условный оператор Если в языке 1С 8.3, 8.2

Автор: | Ноябрь 8, 2019

&НаКлиенте Процедура ВыполнитьКод(Команда)       /// Как составить оператор Если в 1с 8.3, 8.2   Если 1 > 0 Тогда // Истина // блок операторов Сообщить(«Компьютер выполнит все команды из этого блока.»); Сообщить(«Один больше нуля.»); КонецЕсли;   Если 1 < 0 Тогда // Ложь Сообщить(«Один меньше нуля.»); Иначе Сообщить(«Сработает именно эта ветка условного оператора (#А).»); Сообщить(«Один… Читать далее »

Циклы в языке 1С 8.3, 8.2

Автор: | Ноябрь 8, 2019

&НаКлиенте Процедура ВыполнитьКод(Команда)       /// Как организовать цикл в 1с 8.3, 8.2   // Для Цикл Для Счетчик = 1 По 5 Цикл Сообщить(Счетчик); // 1 2 3 4 5 КонецЦикла;   // Для Каждого Цикл   Дни = Новый Массив(); Дни.Добавить(«Понедельник»); Дни.Добавить(«Вторник»); Дни.Добавить(«Среда»);   Для Каждого Элемент Из Дни Цикл Сообщить(Элемент); // Понедельник Вторник… Читать далее »