Архив рубрики: ЗАПИСИ ПРОГРАММИСТА 1С

Принадлежность элемента к группе (ПринадлежитЭлементу)

Определить находиться ли элемент в указанной папке (группе) или нет вместо запроса можно использовать эту функцию Если ОбъектСсылка.ПринадлежитЭлементу(ЭлементСсылка) Тогда Сообщить(«Принадлежит»); КонецЕсли; Пример: Папка = Справочники.Контрагенты.НайтиПоКоду(«00000011»); Если Контрагент.ПринадлежитЭлементу(Папка) Тогда Сообщить(«Принадлежит»); КонецЕсли;

Скопировать таблицу значений 1С (ЗаполнитьЗначенияСвойств)

Для копирования данных из одной таблицы значения в другую в типовых конфигурациях 1с 8 существует процедура модуля ОбщегоНазначения.ЗагрузитьВТаблицуЗначений. Она добавляет в таблицу значений строки из другой таблицы значений, наименования колонок должны совпадать. Процедура ЗагрузитьВТаблицуЗначений(ТаблицаИсточник, ТаблицаПриемник) Экспорт Для каждого СтрокаТаблицыИсточника Из ТаблицаИсточник Цикл СтрокаТаблицыПриемника = ТаблицаПриемник.Добавить(); ЗаполнитьЗначенияСвойств(СтрокаТаблицыПриемника,СтрокаТаблицыИсточника); КонецЦикла; КонецПроцедуры ТаблицаИсточник — таблица значений, откуда берутся значения.… Читать далее »

Тип значения документа, справочника

Для проверки типа документа или справочника В процедуре или функции Если ТипЗнч(Основание) = Тип(«ДокументСсылка.РеализацияТоваровУслуг») Тогда … КонецЕсли; или Если Документ.Ссылка.Метаданные().Имя = «РеализацияТоваровУслуг» Тогда …. КонецЕсли; В запросе выбор когда (Взаиморасчеты.Документ Ссылка Документ.РеализацияТоваровУслуг)

Как получить сумму всех начислений указанному сотруднику в указанном периоде?

ВЫБРАТЬ БУОсновныеНачисления.Организация КАК Организация, ПРЕДСТАВЛЕНИЕ(БУОсновныеНачисления.Организация), БУОсновныеНачисления.ВидРасчета, ПРЕДСТАВЛЕНИЕ(БУОсновныеНачисления.ВидРасчета), БУОсновныеНачисления.Результат КАК Результат, «»Основные»» КАК ВариантНачислений ИЗ РегистрРасчета.БУОсновныеНачисления КАК БУОсновныеНачисления ГДЕ БУОсновныеНачисления.ПериодРегистрации = &НужныйПериод И БУОсновныеНачисления.ФизЛицо = &ФизЛицо ОБЪЕДИНИТЬ ВСЕ ВЫБРАТЬ БУДополнительныеНачисления.Организация, ПРЕДСТАВЛЕНИЕ(БУДополнительныеНачисления.Организация), БУДополнительныеНачисления.ВидРасчета, ПРЕДСТАВЛЕНИЕ(БУДополнительныеНачисления.ВидРасчета), БУДополнительныеНачисления.Результат, «»Дополнительные»» ИЗ РегистрРасчета.БУДополнительныеНачисления КАК БУДополнительныеНачисления ГДЕ БУДополнительныеНачисления.ПериодРегистрации = &НужныйПериод И БУДополнительныеНачисления.ФизЛицо = &ФизЛицо ИТОГИ СУММА(Результат) ПО ОБЩИЕ, Организация, ВариантНачислений

Как получить сумму начисления по конкретному виду расчета указанному сотруднику в указанном периоде?

Запрос = Новый Запрос; Запрос.Текст = «ВЫБРАТЬ | БУОсновныеНачисления.Результат |ИЗ | РегистрРасчета.БУОсновныеНачисления КАК БУОсновныеНачисления |ГДЕ | БУОсновныеНачисления.ПериодРегистрации = &Период | И | БУОсновныеНачисления.ФизЛицо = &ФизЛицо | И | БУОсновныеНачисления.ВидРасчета = &ВидРасчета»; Запрос.УстановитьПараметр(«Период», НачалоМесяца(Период1)); Запрос.УстановитьПараметр(«ВидРасчета», ВидРасчета); Запрос.УстановитьПараметр(«ФизЛицо», ФизЛицо);

Как долларовую сумму вывести прописью по-английски?

ФорматнаяСтрока = «Л=en_US»; ПараметрыПредметаИсчисления = «dollar, dollars, cent, cents, 2»; Сообщить(ЧислоПрописью(Сумма, ФорматнаяСтрока, ПараметрыПредметаИсчисления));

Как вывести прописью число килограммов с указанием дробной части в граммах?

ПараметрыПредметаИсчисления = «килограмм, килограмма, килограммов, м, грамм, грамма, граммов, м, 3»; ФорматнаяСтрока = «Л=ru_RU; ДП=Истина»; Сообщить(ЧислоПрописью(ВыводимоеЧисло, ФорматнаяСтрока, ПараметрыПредметаИсчисления));

Как вывести число прописью по-русски, с указанием сотых в дробной части?

ПараметрыПредметаИсчисления = «целая, целых, целых, ж, сотая, сотой, сотых, ж, 2» ФорматнаяСтрока = «Л=ru_RU; ДП=Истина»; Сообщить(ЧислоПрописью(ВыводимоеЧисло, ФорматнаяСтрока, ПараметрыПредметаИсчисления));

Как применить округление при работе с вычисляемыми числовыми полями в запросе?

ВЫБРАТЬ ПродажиОбороты.Номенклатура, ВЫРАЗИТЬ(ПродажиОбороты.СтоимостьОборот / ПродажиОбороты.КоличествоОборот КАК ЧИСЛО(15, 2)) КАК СредняяЦенаПродажи ИЗ РегистрНакопления.Продажи.Обороты(&ДатаНач, &ДатаКон) КАК ПродажиОбороты

Как можно проверить тип значения переменной на равенство нужному?

ПараметрыПредметаИсчисления = «килограмм, килограмма, килограммов, м, грамм, грамма, граммов, м, 3»; ФорматнаяСтрока = «Л=ru_RU; ДП=Истина»; Сообщить(ЧислоПрописью(ВыводимоеЧисло, ФорматнаяСтрока, ПараметрыПредметаИсчисления));