Архив рубрики: Метаданные

Проверка существования реквизита у объекта метаданных

Автор: | Сентябрь 16, 2020

// Позволяет определить есть ли среди реквизитов шапки Объекта реквизит с переданным именем. Функция ЕстьРеквизитОбъекта(ИмяРеквизита, Объект) Экспорт МетаданныеОбъекта = Объект.Метаданные(); Если МетаданныеОбъекта.Реквизиты.Найти(ИмяРеквизита) = Неопределено Тогда Возврат Ложь; Иначе Возврат Истина; КонецЕсли;  КонецФункции  С давних времен в типовых конфигурациях для этого существовала специальная функция.В конфигурациях последних редакций эта функция стала более универсальной и кроме того стала… Читать далее »

Работа с файловой системой в языке 1С 8.3, 8.2 (в примерах)

Автор: | Сентябрь 4, 2019

&НаСервере Процедура ЧтениеИЗаписьФайловНаСервере()       /// Как записать произвольное значение в файл в 1с 8.3, 8.2   // любое сериализуемое (то есть превращаемое // в строку и обратно) значение можно сохранять // в файл, например, массивы, списки значений, строки // структуры и т.д. Числа = Новый Массив; Числа.Добавить(35); Числа.Добавить(67); ЗначениеВФайл(«c:\числа.txt», Числа); // эта функция работает только… Читать далее »

Принадлежность элемента к группе (ПринадлежитЭлементу)

Определить находиться ли элемент в указанной папке (группе) или нет вместо запроса можно использовать эту функцию Если ОбъектСсылка.ПринадлежитЭлементу(ЭлементСсылка) Тогда Сообщить(«Принадлежит»); КонецЕсли; Пример: Папка = Справочники.Контрагенты.НайтиПоКоду(«00000011»); Если Контрагент.ПринадлежитЭлементу(Папка) Тогда Сообщить(«Принадлежит»); КонецЕсли;

Тип значения документа, справочника

Для проверки типа документа или справочника В процедуре или функции Если ТипЗнч(Основание) = Тип(«ДокументСсылка.РеализацияТоваровУслуг») Тогда … КонецЕсли; или Если Документ.Ссылка.Метаданные().Имя = «РеализацияТоваровУслуг» Тогда …. КонецЕсли; В запросе выбор когда (Взаиморасчеты.Документ Ссылка Документ.РеализацияТоваровУслуг)

Работа с датой в 1С 8.x

Как явно указать нужную дату? Как проверить дату на пустое значение? Как сравнить две даты (дни)? Как прибавить к дате день, месяц? Как явно указать нужную дату? ‘20050308’ Дата(2005, 1, 1) Дата(1, 1, 1) Дата(2005, 1, 1, 10, 29, 50) ДАТАВРЕМЯ(2005, 01, 01) Как проверить дату на пустое значение? Если ДатаПроверяемая = Дата(1, 1, 1)… Читать далее »