Архив рубрики: Таблицы, массивы

Работа с типом Дата в языке 1С 8.3, 8.2

Автор: | Ноябрь 8, 2019

&НаКлиенте Процедура ВыполнитьКод(Команда)       /// Как инициализировать дату константой в 1с 8.3, 8.2   Дата = ‘20130724’; // 24.07.2013       /// Как преобразовать строку в дату в 1с 8.3, 8.2   Дата = Дата(«20130724»); // 24.07.2013       /// Как инициализировать дату отдельными компонентами в 1с 8.3, 8.2   Дата = Дата(2013, 07, 24); // 24.07.2013… Читать далее »

Циклы в языке 1С 8.3, 8.2

Автор: | Ноябрь 8, 2019

&НаКлиенте Процедура ВыполнитьКод(Команда)       /// Как организовать цикл в 1с 8.3, 8.2   // Для Цикл Для Счетчик = 1 По 5 Цикл Сообщить(Счетчик); // 1 2 3 4 5 КонецЦикла;   // Для Каждого Цикл   Дни = Новый Массив(); Дни.Добавить(«Понедельник»); Дни.Добавить(«Вторник»); Дни.Добавить(«Среда»);   Для Каждого Элемент Из Дни Цикл Сообщить(Элемент); // Понедельник Вторник… Читать далее »

Математика (числа) в языке 1С 8.3, 8.2

Автор: | Ноябрь 8, 2019

&НаКлиенте Процедура ВыполнитьКод(Команда)       /// Как округлить число в 1с 8.3, 8.2   // до первого знака после запятой // случай когда (N + 1) знак < 5 Сообщить(Окр(321.123, 1)); // 321.1   // до первого знака после запятой // случай когда (N + 1) знак >= 5 Сообщить(Окр(321.163, 1)); // 321.2   // особый… Читать далее »

Скопировать таблицу значений 1С (ЗаполнитьЗначенияСвойств)

Для копирования данных из одной таблицы значения в другую в типовых конфигурациях 1с 8 существует процедура модуля ОбщегоНазначения.ЗагрузитьВТаблицуЗначений. Она добавляет в таблицу значений строки из другой таблицы значений, наименования колонок должны совпадать. Процедура ЗагрузитьВТаблицуЗначений(ТаблицаИсточник, ТаблицаПриемник) Экспорт Для каждого СтрокаТаблицыИсточника Из ТаблицаИсточник Цикл СтрокаТаблицыПриемника = ТаблицаПриемник.Добавить(); ЗаполнитьЗначенияСвойств(СтрокаТаблицыПриемника,СтрокаТаблицыИсточника); КонецЦикла; КонецПроцедуры ТаблицаИсточник — таблица значений, откуда берутся значения.… Читать далее »

Работа со списком значений в 1С 8.x

Как создать список значений? Как добавить элементы в список значений? Как найти элемент списка значений? Как обратиться к элементу списка значений? Как перебрать элементы списка значений? Как удалить элемент списка значений? Выгрузка данных из таблицы значений в список значений Как создать список значений? СозданныйСписок = Новый СписокЗначений; Как добавить элементы в список значений? СписокСотрудников.Добавить(ТекущийСотрудник, ТекущийСотрудник.ФИО,… Читать далее »