Перенумерация документов

Перенумерация документов

 В своей практике я не раз сталкивался с ситуацией, когда пользователи 1С меняя нумерацию вручную убирали лидирующие нули и таким образом сбивали автоматическую нумерацию. Что делать? Как...

Нумерация документов

Нумерация документов

Достаточно отредактировать один раз номер. Например в 1С 8.2 Торговле. Описываем ситуацию. Отредактировали номер у документа, а следующий не записывается сообщая что номер не уникален или просто...

Выгрузка/Загрузка Пользователей системы 1С

Выгрузка/Загрузка Пользователей системы 1С

Внешняя обработка ВыгрузкаЗагрузкаПользователей.epf предназначена

Замена ссылок в документах и справочниках

Замена ссылок в документах и справочниках

Нередки случаи когда пользователи конфигураций 1С сталкиваются с проблемой возникновения дублей объектов информационной базы. Причины их возникновения мы рассматривать не будем,а рассмотрим как...

Свертка базы данных в 1С

Свертка базы данных в 1С

Свертка базы данных в 1С - это удаление данных, как правило документов, за прошлые отчётные периоды, по которым зафиксированы результаты хозяйственной деятельности, и данные не меняются.

Счет-фактуры выданные для указанных документов Реализация товаров и услуг

Счет-фактуры выданные для указанных документов Реализация товаров и услуг

Обработка автоматически создает документы “Счет-фактура выданный” для указанных документов “Реализация товаров и услуг” и проводит их.

Дата запрета изменения данных в 1с 8

Дата запрета изменения данных в 1с 8

Бухгалтерский и оперативный учет часто нуждается в блокировке данных за прошедший период. Особенно это актуально когда годовые отчеты сданы и документы все сверены. Период нужно "закрыть", чтобы...

Ошибка "Нарушена целостность структуры конфигурации"

Один из многих вариантов решения ошибки "Нарушена целостность структуры конфигурации".Если Вам довелось столкнуться с этой ошибкой обратитесь к специалисту 1С однозначно. Вариантов решения много,...

Удаление помеченных объектов

Удаление помеченных объектов

Модифицированная обработка «Удаление помеченных объектов»

Внутренняя ошибка компоненты dbeng8

Частая ошибка при активной работе всякого рода обработками. Поможет: Способ 1. В конфигураторе - Администрирование - Тестирование и исправление ошибок. Способ 2. Файл chdbfl.exe, который...

Реестр в ФСС

Реестр в ФСС

Данный обработка - внешний отчет, создан для конфигурации 1C "Зарплата и управление кадрами".  

Изменения конфигурации заблокированы средствами распределенной ИБ

Изменения конфигурации заблокированы средствами распределенной ИБ

Довольно редко, но встречается дополнительная блокировка информационной базы. При обновлении наталкивается что обновление и изменение поддежки не доступны, а рядом с замочком висит второй с...

Заполнение документа Реализация товаров и услуг по документу Заказ покупателя без учета остатков (УТ 10.3)

Заполнение документа Реализация товаров и услуг по документу Заказ покупателя без учета остатков (УТ 10.3)

В УТ 10.3 даже  при установленных флажках в Настройке дополнительных прав у пользователя Разрешить превышение остатка на складе и Разрешить превышение остатка товаров организации не заполняется...

Расходы будущих периодов (страхование)

Необходимо страхование гражданское отразить ввиде расходов будущих периодов, обязательно по разным подразделениям и статьям затрат (20 и 23, 25). Как это лучше реализовать в Бухгалтерии 2.0 Для...

Уполномоченные лица в 1С:Бухгалтерии 8

В 1С:Бухалтерии 8 появилась возможность в документах по реализации товаров и услуг и счетах-фактурах для автоматического вывода на печать указать ответственных лиц, подписывающих документы в полях...

Резервы по сомнительным долгам в 1С:Бухгалтерия 8

Внимание! В 1С:Бухгалтерия 8 ред. 2.0, начиная с релиза конфигурации 2.0.37.8, автоматизирован расчет резервов по сомнительным долгам в соответствии с п.70 Положения по ведению бухгалтерского учета...

Распределение входящего НДС при совмещении режимов налогообложения в программе "1С:Бухгалтерия"

При распределении НДС по косвенным расходам (совмещение ОСН и ЕНВД) в книгу покупок попадает не возмещаемая, а вся сумма входящего НДС и одновременно в книгу продаж невозмещаемая сумма. Есть две...

1С: Предприниматель 8

1С: Предприниматель 8

Программа "1С:Предприниматель 8" предназначена для индивидуальных предпринимателей (ИП). 1С Предприниматель - это готовое решение для ведения учета и составления отчетности. Программный продукт "1С...

Чтение и запись XML в языке 1С 8.3, 8.2

/// Как прочитать файл в формате XML через DOM /// в 1с 8.3, 8.2   &НаСервере Процедура ПрочитатьФайлXMLЧерезDOM(ПутьКФайлу)  

Пустая дата в 1С

В текстах модулей Если Дата = '00010101' Тогда Если Дата = '00010101000000' Тогда Если Дата = '0001-01-01' Тогда Если Дата = Дата(1, 1, 1) Тогда В запросах ГДЕ Дата =...

Как прибавить к дате день, месяц в 1С

СледующийДень = ТекущаяДата() + 60 * 60 * 24; ДобавитьМесяц(Дата(2005, 1, 31), 1); ДобавитьМесяц(Дата(2005, 2, 28), -1); КонецМесяца(ДобавитьМесяц(Дата(2005, 2, 28), -1)); Функция...

Работа с массивами в 1С 8.x

  Как создать массив? Как создать многомерный массив? Как добавить элементы в массив? Как определить размер массива? Как обратиться к элементу массива? Как перебрать элементы массива? Как...

Обновление распределенной информационной базы (РИБ)

Правильное обновление 1С при использовании обмена РИБ.

Построитель отчёта и таблица значений

Таблица значений была обработана построителем отчета 

Чтение данных с листа Excel

Функция ПрочитатьЛистExcel(ТЗ = Неопределено, ЛистЭксель = Неопределено,НомерПервойСтроки = 1, НомерПервойКолонки = 1, ВсегоСтрок = 0, ВсегоКолонок = 0) Экспорт

Функций по работе со строками

Здесь в краткой форме приведу функций по работе со строками:

GUID, ГУИД, уникальный идентификатор

«GUID (Globally Unique Identifier) — статистически уникальный 128-битный идентификатор. Его главная особенность — уникальность, которая позволяет создавать расширяемые сервисы и приложения без...

Дата запрета программно в УТ 10, КОРП и УПП

Если Вам необходимо программно изменить Дату запрета по своим параметрам. Добавляем в модуле сеанса:  КоличествоДней = 5; Попытка ДатаУстановки = НачалоДня(ТекущаяДата()) -...

Сократить ФИО

Функция ФИО(Сотрудник) Экспорт Перем ПолноеИмя, Фамилия, ИмяОтчество, Имя, Отчество; Перем ПозицияПервогоПробела, ПозицияВторогоПробела; ПолноеИмя = Сотрудник.Наименование; ПозицияПервогоПробела =...

Как сравнивать типы значений

В 1С есть две функции, с помощью которых можно производить операции с типами. 

Контроль остатков в УТ 10.3

Меню: Сервис - Пользователи - Настройка дополнительных прав: - Разрешить превышение остатков на складе; - Разрешить превышение остатков организации.

Учет выплаченных и полученных дивидендов в "1С:Бухгалтерии 8" ред. 3.0

Компания может распределять прибыль между участниками (акционерами) ежеквартально, раз в полгода или раз в год. О том, как изменился с 1 января порядок исчисления налогов с дивидендов по акциям мы...

Тип документа 1с 8.x

 В ЗАПРОСЕ: ... ДокументСсылка ССЫЛКА Документ.Поступление ... В ТЕКСТЕ: Если ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.Поступление")  Тогда

Настройка журнала регистрации в 1С 8.2 (8.3)

Журнал регистрации 1С — специальный механизм платформы 1С версий 8.2 и 8.3, который позволяет фиксировать работу пользователей с системой. С помощью журнала можно узнать кто и когда изменял объекты...

Выгрузка / Загрузка данных посредством текстовых (TXT) файлов

Для работы с текстовыми документами существуют три типа данных – ТекстовыйДокумент, ЗаписьТекста и ЧтениеТекста. Разница двух подходов состоит в способе загрузки документа: ТекстовыйДокумент...

Создание документа Операция Бух программно

ДокОперация = Документы.ОперацияБух.СоздатьДокумент();

Печать ценников любого размера, УТ 10.3, БП 2.0

Обработка предназначена для редактирования ценников.

Запросы в 1С

 Примеры запросов в 1С 8 Как в запросе 1с8 установить условие проверки периода на конец дня? Как правильно обрабатывать значения NULL в запросе 1С8? Как вывести результат запроса в табличный...

Как определить программно, существует ли у документа 1С требуемый реквизит

Вопрос Как определить программно, существует ли у документа требуемый реквизит Ответ В типовых конфигурациях 1С для этой цели используется функция «ЕстьРеквизитДокумента» общего модуля...

Копирование регистра 1с

Порой для уже отрытых конфигураций необходимо создать идентичную копию регистра для работы с ней по новым правилам установленным заказчиком. Часто такую задачу делают для аналитических отделов...

тип документа в запросе 1с

ХозрасчетныйОбороты.Регистратор ССЫЛКА Документ.ПоступлениеТоваровУслуг

Количество субконто счета %s превышает максимально возможное!

Количество субконто счета %s превышает максимально возможное!

Ошибка выходит при обновлении или добавлении нового счета в план счетов. Заходим в Конфигурацию. Находим Планы счетов необходимый нам список. Меняем "Максимальное кличество счетов"  

Форма выбора с отбором

СтандартнаяОбработка = Ложь; ФормаВыбора = Справочники.Номенклатура.ПолучитьФормуВыбора(, Элемент);Если ЗначениеЗаполнено(Значение) Тогда ФормаВыбора.ЭлементыФормы.СправочникСписок.ТекущаяСтрока =...

Как редактировать записи в списке (8.2, 8.3) ?

ЭлементыФормы.СписокДоговорыПайщиков.СпособРедактирования = СпособРедактированияСписка.ВСписке;

8.Х. Как добавить записи в независимый регистр сведений?

Случай 1.МенеджерЗаписи = РегистрыСведений.ЗначенияСвойствОбъектов.СоздатьМенеджерЗаписи(); МенеджерЗаписи.Объект = ПолеВводаНоменклатура; МенеджерЗаписи.Свойство =...

Список значений в языке 1С 8.3, 8.2 (в примерах)

&НаКлиенте Процедура ВыполнитьКод(Команда)       /// Как создать список значений в 1с 8.3, 8.2   Список = Новый СписокЗначений;       /// Как добавить элемент в список значений в 1с...

Тип Структура в языке 1С 8.3, 8.2 (в примерах)

&НаКлиенте Процедура ВыполнитьКод(Команда)       /// Как создать структуру (способ 1) в 1с 8.3, 8.2  

Таблица значений в языке 1С 8.3, 8.2 (в примерах)

&НаСервере Процедура ВыполнитьКодНаСервере()       /// Как создать таблицу значений в 1с 8.3, 8.2  

Работа с файловой системой в языке 1С 8.3, 8.2 (в примерах)

&НаСервере Процедура ЧтениеИЗаписьФайловНаСервере()       /// Как записать произвольное значение в файл в 1с 8.3, 8.2  

Функция Формат в языке 1С 8.3, 8.2 (в примерах)

&НаКлиенте Процедура ВыполнитьКод(Команда)       /// Как указать общее число цифр в 1с 8.3, 8.2

Тип Соответствие в языке 1С 8.3, 8.2 (в примерах)

&НаКлиенте Процедура ВыполнитьКод(Команда)       /// Как создать соответствие в 1с 8.3, 8.2  

Как вычислить формулу в строке?

ЧисловойРезультат=Вычислить(СтроковыйПараметр)

Изменение записей независимого регистра сведений

Вариант 1. Менеджер = РегистрыСведений.МойРегистр.СоздатьМенеджерЗаписи(); Менеджер.Контрагент = ИмяКонтраг1; Менеджер.Прочитать(); Если Менеджер.Выбран() Тогда ...

Транзакция

Разработчик может и сам создать транзакцию. Для выполнения действий в транзакции необходимо в код активировать её: НачатьТранзакцию(); По окончании транзакции её необходимо...

1С отборы в форме выбора

Процедура СобытиеНачалоВыбора(Элемент, СтандартнаяОбработка) СтандартнаяОбработка = Ложь; ФормаВыбора = Документы.Документ1.ПолучитьФормуВыбора(,...

Обнаружена незавершенная операция обновления конфигурации бд

Восстановление при некорректном обновлении конфигурации. Обнаружена незавершенная операция обновления конфигурации бд

Перенос строки

Пример: НаборСтрок = "Первая строка"+Символы.ПС+ "Вторая строка"+Символы.ПС+ "Третья строка"; В конструкции Символы также содержаться: ВК (CR) — возврат...

Табличное поле в 1С 8.x

Табличное поле в 1С 8.x Как запретить пользователю изменять порядок следования колонок в табличном поле? Как запретить пользователю изменять любые настройки колонок табличного поля? Как...

  • Перенумерация документов

    Перенумерация документов

  • Нумерация документов

    Нумерация документов

  • Выгрузка/Загрузка Пользователей системы 1С

    Выгрузка/Загрузка Пользователей системы 1С

  • Замена ссылок в документах и справочниках

    Замена ссылок в документах и справочниках

  • Свертка базы данных в 1С

    Свертка базы данных в 1С

  • Счет-фактуры выданные для указанных документов Реализация товаров и услуг

    Счет-фактуры выданные для указанных документов Реализация товаров и услуг

  • Дата запрета изменения данных в 1с 8

    Дата запрета изменения данных в 1с 8

  • Ошибка "Нарушена целостность структуры конфигурации"

  • Удаление помеченных объектов

    Удаление помеченных объектов

  • Внутренняя ошибка компоненты dbeng8

  • Реестр в ФСС

    Реестр в ФСС

  • Изменения конфигурации заблокированы средствами распределенной ИБ

    Изменения конфигурации заблокированы средствами распределенной ИБ

  • Заполнение документа Реализация товаров и услуг по документу Заказ покупателя без учета остатков (УТ 10.3)

    Заполнение документа Реализация товаров и услуг по документу Заказ покупателя без учета остатков (УТ 10.3)

  • Расходы будущих периодов (страхование)

  • Уполномоченные лица в 1С:Бухгалтерии 8

  • Резервы по сомнительным долгам в 1С:Бухгалтерия 8

  • Распределение входящего НДС при совмещении режимов налогообложения в программе "1С:Бухгалтерия"

  • 1С: Предприниматель 8

    1С: Предприниматель 8

  • Чтение и запись XML в языке 1С 8.3, 8.2

  • Пустая дата в 1С

  • Как прибавить к дате день, месяц в 1С

  • Табличный документ, текстовый документ в 1С 8.x

  • Функция Формат в языке 1С 8.3, 8.2 (в примерах)

  • Работа с массивами в 1С 8.x

  • Обновление распределенной информационной базы (РИБ)

  • Построитель отчёта и таблица значений

  • Чтение данных с листа Excel

  • Функций по работе со строками

  • GUID, ГУИД, уникальный идентификатор

  • Дата запрета программно в УТ 10, КОРП и УПП

  • Сократить ФИО

  • Как сравнивать типы значений

  • Контроль остатков в УТ 10.3

  • Учет выплаченных и полученных дивидендов в "1С:Бухгалтерии 8" ред. 3.0

  • Тип документа 1с 8.x

  • Настройка журнала регистрации в 1С 8.2 (8.3)

  • Выгрузка / Загрузка данных посредством текстовых (TXT) файлов

  • Создание документа Операция Бух программно

  • Печать ценников любого размера, УТ 10.3, БП 2.0

  • Запросы в 1С

  • Как определить программно, существует ли у документа 1С требуемый реквизит

  • Как программно изменить проводку в Регистре Бухгалтерии?

  • Копирование регистра 1с

  • тип документа в запросе 1с

  • Количество субконто счета %s превышает максимально возможное!

    Количество субконто счета %s превышает максимально возможное!

  • Форма выбора с отбором

  • Как редактировать записи в списке (8.2, 8.3) ?

  • 8.Х. Как добавить записи в независимый регистр сведений?

  • Список значений в языке 1С 8.3, 8.2 (в примерах)

  • Тип Структура в языке 1С 8.3, 8.2 (в примерах)

  • Таблица значений в языке 1С 8.3, 8.2 (в примерах)

  • Работа с файловой системой в языке 1С 8.3, 8.2 (в примерах)

  • Функция Формат в языке 1С 8.3, 8.2 (в примерах)

  • Тип Соответствие в языке 1С 8.3, 8.2 (в примерах)

  • Как вычислить формулу в строке?

  • Изменение записей независимого регистра сведений

  • Транзакция

  • 1С отборы в форме выбора

  • Обнаружена незавершенная операция обновления конфигурации бд

  • Перенос строки

  • Табличное поле в 1С 8.x

Таблица значений в языке 1С 8.3, 8.2 (в примерах)

&НаСервере
Процедура ВыполнитьКодНаСервере()
 
    /// Как создать таблицу значений в 1с 8.3, 8.2
 
    // с таблицей значений можно работать только на сервере 
    Таб = Новый ТаблицаЗначений;    
 
    /// Как добавить колонки в таблицу значений в 1с 8.3, 8.2
 
    Таб.Колонки.Добавить("Фрукт");
    Таб.Колонки.Добавить("Цвет");
    Таб.Колонки.Добавить("Вкус");
 
    /// Как добавить строки в таблицу значений в 1с 8.3, 8.2
 
    Стр = Таб.Добавить();
    Стр.Фрукт = "Яблоко";
    Стр.Цвет = "Зелёный";
    Стр.Вкус = "Кислый";
 
    Стр = Таб.Добавить();
    Стр.Фрукт = "Банан";
    Стр.Цвет = "Желтый";
    Стр.Вкус = "Сладкий";
 
    Стр = Таб.Добавить();
    Стр.Фрукт = "Слива";
    Стр.Цвет = "Синий";
    Стр.Вкус = "Терпкий"; 
 
    /// Как добавить в таблицу значений колонку с
    /// описанием типа и заголовка в 1с 8.3, 8.2
 
    ОписаниеВеса = Новый ОписаниеТипов("Число",
        Новый КвалификаторыЧисла(12, 3));
 
    Таб.Колонки.Добавить("ВесФрукта", ОписаниеВеса, "Вес фрукта");
    Таб[0].ВесФрукта = 100.005;
    Таб[1].ВесФрукта = 60.010;
    Таб[2].ВесФрукта = 25.000;
 
    /// Как перечислить все строки в таблице значений в 1с 8.3, 8.2
 
    Для Каждого Стр Из Таб Цикл
        Сообщить(Стр.Фрукт + " " + Стр.Цвет + " " + Стр.Вкус +
            " " + Стр.ВесФрукта);
    КонецЦикла;
 
    /// Как перечислить все колонки в таблице значений
    /// в 1с 8.3, 8.2
 
    Для Каждого Колонка Из Таб.Колонки Цикл
        Сообщить(Колонка.Имя);
    КонецЦикла; 
 
    /// Как выгрузить колонку таблицы значений в массив в 1с 8.3, 8.2
 
    // выгрузка названий фруктов в массив
    МассивФруктов = Таб.ВыгрузитьКолонку("Фрукт");
 
    // ничего не измениться, так как массив не менялся
    Таб.ЗагрузитьКолонку(МассивФруктов, "Фрукт");
 
    /// Как заполнить значения в колонке для всех строк таблицы 
    /// значений в 1с 8.3, 8.2
 
    // обнулим вес во всех строках
    Таб.ЗаполнитьЗначения(0, "ВесФрукта");
 
    // выставим новые веса
    Таб[0].ВесФрукта = 100;
    Таб[1].ВесФрукта = 60;
    Таб[2].ВесФрукта = 25;
 
    /// Как в таблице значений посчитать итог по колонке в 1с 8.3, 8.2
 
    Сообщить(Таб.Итог("ВесФрукта")); // 185
 
    /// Как найти строку в таблице значений по значению в 1с 8.3, 8.2
 
    // найдём строчку с яблоком и покажем его цвет
    НайденнаяСтрока = Таб.Найти( "Яблоко" );
    Если НайденнаяСтрока <> Неопределено Тогда
        Сообщить(НайденнаяСтрока.Цвет); // Зелёный
    КонецЕсли;
 
    /// Как найти строку в таблице значений поиском значения
    /// в определенных колонках в 1с 8.3, 8.2
 
    // будем искать по слову "Кислый" в колонках вкус и цвет
    НайденнаяСтрока = Таб.Найти("Кислый", "Вкус, Цвет");
    Если НайденнаяСтрока <> Неопределено Тогда
        Сообщить(НайденнаяСтрока.Фрукт); // Яблоко
    КонецЕсли;
 
    // добавим ещё один зелёный фрукт
    Стр = Таб.Добавить();
    Стр.Фрукт = "Киви";
    Стр.Цвет = "Зелёный";
    Стр.Вкус = "Сладкий";
    Стр.ВесФрукта = 30;
 
    /// Как искать в таблице значений неуникальные значения
    /// в 1с 8.3, 8.2
 
    Отбор = Новый Структура;
    Отбор.Вставить("Цвет", "Зелёный");
    Строки = Таб.НайтиСтроки(Отбор);
    Для Каждого Стр Из Строки Цикл
        Сообщить(Стр.Фрукт); // Яблоко Киви
    КонецЦикла;
 
    /// Как сдвинуть строку таблицы значений в 1с 8.3, 8.2
 
    // сдвигаем первую строку на одну позицию вперёд
    Таб.Сдвинуть(0, 1);
 
    // и возвращаем обратно
    Таб.Сдвинуть(1, -1);
 
    /// Как создать копию таблицы значений в 1с 8.3, 8.2
 
    // полная копия
    КопияТаб = Таб.Скопировать();
 
    /// Как создать копию таблицы значений по нужным колонкам
    /// в 1с 8.3, 8.2
 
    // только две колонки будет Фрукт и Цвет
    КопияТаб = Таб.СкопироватьКолонки("Фрукт, Цвет");
 
    /// Как создать копию таблицы значений по отбору в 1с 8.3, 8.2
 
    Отбор = Новый Структура;
    Отбор.Вставить("Фрукт", "Яблоко");
 
    // таблица будет содержать только строчку с яблоком
    КопияТаб = Таб.Скопировать(Отбор);
 
    // таблица будет содержать цвет и вес яблока
    КопияТаб = Таб.Скопировать(Отбор, "Цвет, ВесФрукта");
 
    /// Как свернуть таблицу значений по колонке в 1с 8.3, 8.2
 
    // свернём по вкусу, просуммируем по весу
    Таб.Свернуть("Вкус", "ВесФрукта");
 
    /// Как отсортировать таблицу значений по колонке в 1с 8.3, 8.2
 
    Таб.Сортировать("ВесФрукта Возр");
 
    /// Как отсортировать таблицу значений по нескольким колонкам
    /// в 1с 8.3, 8.2
 
    Таб.Сортировать("ВесФрукта Возр, Вкус Убыв");
 
    /// Как удалить строку из таблицы значений в 1с 8.3, 8.2
 
    // по индексу или по значению
    Таб.Удалить(0);
 
КонецПроцедуры
 
/// Как программно вывести таблицу значений на
/// форму в 1с 8.3, 8.2 
 
// см. примеры использования этой функции ниже
 
// ТабВКоде - таблица значений, созданная программно
// ТабРеквизит - имя реквизита формы типа ТаблицаЗначений
// ТабНаФорме - имя элемента формы, связанного с ТабРеквизит 
 
&НаСервере
Процедура ВывестиТаблицуЗначенияВКодеВТаблицуНаФорме(ТабВКоде, ТабРеквизит, ТабНаФорме)
 
    // реквизит ТабРеквизит и соответствующий
    // ему элемент формы ТабНаФорме уже созданы
    // нами в визуальном режиме
 
    // 1. добавляем колонки из ТабВкоде в реквизит ТабРеквизит
 
    НовыеРеквизиты = Новый Массив;
 
    Для Каждого Колонка Из ТабВКоде.Колонки Цикл
         НовыеРеквизиты.Добавить(
            Новый РеквизитФормы(
                Колонка.Имя, Колонка.ТипЗначения,
                ТабРеквизит
            )
         );
    КонецЦикла;
 
    ИзменитьРеквизиты(НовыеРеквизиты);
 
    // 2. добавляем колонки из ТабВКоде в элемент ТабНаФорме
 
    Для Каждого Колонка Из ТабВКоде.Колонки Цикл
 
        НовыйЭлемент = Элементы.Добавить(
            ТабРеквизит + "_" + Колонка.Имя, Тип("ПолеФормы"), Элементы[ТабНаФорме]
        );
        НовыйЭлемент.Вид = ВидПоляФормы.ПолеВвода;
        НовыйЭлемент.ПутьКДанным = ТабРеквизит + "." + Колонка.Имя;
    КонецЦикла;
 
    // 3. наконец, передаём данные из ТабВКоде в ТабРеквизит
 
    ЗначениеВРеквизитФормы(ТабВКоде, ТабРеквизит);
 
    // готово!    
 
КонецПроцедуры
 
&НаСервере
Процедура СоздатьТаблицуНаФормеНаСервере()
 
    // программно создаём таблицу значений ТабВКоде
 
    ТабВКоде = Новый ТаблицаЗначений;
 
    ОписаниеСтроки = Новый ОписаниеТипов("Строка");
    ОписаниеВеса = Новый ОписаниеТипов("Число",
        Новый КвалификаторыЧисла(12, 3));
 
    ТабВКоде.Колонки.Добавить("Фрукт", ОписаниеСтроки, "Имя фрукта");
    ТабВКоде.Колонки.Добавить("Цвет", ОписаниеСтроки, "Цвет фрукта");
    ТабВКоде.Колонки.Добавить("Вес", ОписаниеВеса, "Вес фрукта");
 
    Стр = ТабВКоде.Добавить();
    Стр.Фрукт = "Яблоко";
    Стр.Цвет = "Зелёный";
    Стр.Вес = 200;
 
    Стр = ТабВКоде.Добавить();
    Стр.Фрукт = "Банан";
    Стр.Цвет = "Желтый";
    Стр.Вес = 150;
 
    ВывестиТаблицуЗначенияВКодеВТаблицуНаФорме(ТабВКоде, "ТабРеквизит1", "ТабНаФорме1");
 
КонецПроцедуры
 
/// Как программно вывести на форму результат запроса
/// в виде таблицы значений в 1с 8.3, 8.2
 
&НаСервере
Процедура ВывестиНаФормуРезультатЗапросаНаСервере()        
 
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        |   Товары.Ссылка,
        |   Товары.ВерсияДанных,
        |   Товары.ПометкаУдаления,
        |   Товары.Код,
        |   Товары.Наименование,
        |   Товары.Цвет,
        |   Товары.ЕдиницаИзмерений,
        |   Товары.Предопределенный,
        |   Товары.ИмяПредопределенныхДанных
        |ИЗ
        |   Справочник.Товары КАК Товары";
 
    РезультатЗапроса = Запрос.Выполнить();
 
    ТабВКоде = РезультатЗапроса.Выгрузить(ОбходРезультатаЗапроса.Прямой);   
 
    // функция ВывестиТаблицуЗначенияВКодеВТаблицуНаФорме определена выше
    ВывестиТаблицуЗначенияВКодеВТаблицуНаФорме(ТабВКоде, "ТабРеквизит2", "ТабНаФорме2");
 
КонецПроцедуры
 
/// Скачать и выполнить эти примеры на компьютере

Похожие статьи:

Полезные обработки и отчеты

Полезные советы по БУ в 1С

JoomShaper Яндекс.Метрика Проверка PR и ТИЦ