Перенумерация документов

Перенумерация документов

 В своей практике я не раз сталкивался с ситуацией, когда пользователи 1С меняя нумерацию вручную убирали лидирующие нули и таким образом сбивали автоматическую нумерацию. Что делать? Как...

Нумерация документов

Нумерация документов

Достаточно отредактировать один раз номер. Например в 1С 8.2 Торговле. Описываем ситуацию. Отредактировали номер у документа, а следующий не записывается сообщая что номер не уникален или просто...

Выгрузка/Загрузка Пользователей системы 1С

Выгрузка/Загрузка Пользователей системы 1С

Внешняя обработка ВыгрузкаЗагрузкаПользователей.epf предназначена

Замена ссылок в документах и справочниках

Замена ссылок в документах и справочниках

Нередки случаи когда пользователи конфигураций 1С сталкиваются с проблемой возникновения дублей объектов информационной базы. Причины их возникновения мы рассматривать не будем,а рассмотрим как...

Свертка базы данных в 1С

Свертка базы данных в 1С

Свертка базы данных в 1С - это удаление данных, как правило документов, за прошлые отчётные периоды, по которым зафиксированы результаты хозяйственной деятельности, и данные не меняются.

Счет-фактуры выданные для указанных документов Реализация товаров и услуг

Счет-фактуры выданные для указанных документов Реализация товаров и услуг

Обработка автоматически создает документы “Счет-фактура выданный” для указанных документов “Реализация товаров и услуг” и проводит их.

Дата запрета изменения данных в 1с 8

Дата запрета изменения данных в 1с 8

Бухгалтерский и оперативный учет часто нуждается в блокировке данных за прошедший период. Особенно это актуально когда годовые отчеты сданы и документы все сверены. Период нужно "закрыть", чтобы...

Ошибка "Нарушена целостность структуры конфигурации"

Один из многих вариантов решения ошибки "Нарушена целостность структуры конфигурации".Если Вам довелось столкнуться с этой ошибкой обратитесь к специалисту 1С однозначно. Вариантов решения много,...

Удаление помеченных объектов

Удаление помеченных объектов

Модифицированная обработка «Удаление помеченных объектов»

Внутренняя ошибка компоненты dbeng8

Частая ошибка при активной работе всякого рода обработками. Поможет: Способ 1. В конфигураторе - Администрирование - Тестирование и исправление ошибок. Способ 2. Файл chdbfl.exe, который...

Реестр в ФСС

Реестр в ФСС

Данный обработка - внешний отчет, создан для конфигурации 1C "Зарплата и управление кадрами".  

Изменения конфигурации заблокированы средствами распределенной ИБ

Изменения конфигурации заблокированы средствами распределенной ИБ

Довольно редко, но встречается дополнительная блокировка информационной базы. При обновлении наталкивается что обновление и изменение поддежки не доступны, а рядом с замочком висит второй с...

Заполнение документа Реализация товаров и услуг по документу Заказ покупателя без учета остатков (УТ 10.3)

Заполнение документа Реализация товаров и услуг по документу Заказ покупателя без учета остатков (УТ 10.3)

В УТ 10.3 даже  при установленных флажках в Настройке дополнительных прав у пользователя Разрешить превышение остатка на складе и Разрешить превышение остатка товаров организации не заполняется...

Расходы будущих периодов (страхование)

Необходимо страхование гражданское отразить ввиде расходов будущих периодов, обязательно по разным подразделениям и статьям затрат (20 и 23, 25). Как это лучше реализовать в Бухгалтерии 2.0 Для...

Уполномоченные лица в 1С:Бухгалтерии 8

В 1С:Бухалтерии 8 появилась возможность в документах по реализации товаров и услуг и счетах-фактурах для автоматического вывода на печать указать ответственных лиц, подписывающих документы в полях...

Резервы по сомнительным долгам в 1С:Бухгалтерия 8

Внимание! В 1С:Бухгалтерия 8 ред. 2.0, начиная с релиза конфигурации 2.0.37.8, автоматизирован расчет резервов по сомнительным долгам в соответствии с п.70 Положения по ведению бухгалтерского учета...

Распределение входящего НДС при совмещении режимов налогообложения в программе "1С:Бухгалтерия"

При распределении НДС по косвенным расходам (совмещение ОСН и ЕНВД) в книгу покупок попадает не возмещаемая, а вся сумма входящего НДС и одновременно в книгу продаж невозмещаемая сумма. Есть две...

1С: Предприниматель 8

1С: Предприниматель 8

Программа "1С:Предприниматель 8" предназначена для индивидуальных предпринимателей (ИП). 1С Предприниматель - это готовое решение для ведения учета и составления отчетности. Программный продукт "1С...

Чтение и запись XML в языке 1С 8.3, 8.2

/// Как прочитать файл в формате XML через DOM /// в 1с 8.3, 8.2   &НаСервере Процедура ПрочитатьФайлXMLЧерезDOM(ПутьКФайлу)  

Пустая дата в 1С

В текстах модулей Если Дата = '00010101' Тогда Если Дата = '00010101000000' Тогда Если Дата = '0001-01-01' Тогда Если Дата = Дата(1, 1, 1) Тогда В запросах ГДЕ Дата =...

Как прибавить к дате день, месяц в 1С

СледующийДень = ТекущаяДата() + 60 * 60 * 24; ДобавитьМесяц(Дата(2005, 1, 31), 1); ДобавитьМесяц(Дата(2005, 2, 28), -1); КонецМесяца(ДобавитьМесяц(Дата(2005, 2, 28), -1)); Функция...

Работа с массивами в 1С 8.x

  Как создать массив? Как создать многомерный массив? Как добавить элементы в массив? Как определить размер массива? Как обратиться к элементу массива? Как перебрать элементы массива? Как...

Обновление распределенной информационной базы (РИБ)

Правильное обновление 1С при использовании обмена РИБ.

Построитель отчёта и таблица значений

Таблица значений была обработана построителем отчета 

Чтение данных с листа Excel

Функция ПрочитатьЛистExcel(ТЗ = Неопределено, ЛистЭксель = Неопределено,НомерПервойСтроки = 1, НомерПервойКолонки = 1, ВсегоСтрок = 0, ВсегоКолонок = 0) Экспорт

Функций по работе со строками

Здесь в краткой форме приведу функций по работе со строками:

GUID, ГУИД, уникальный идентификатор

«GUID (Globally Unique Identifier) — статистически уникальный 128-битный идентификатор. Его главная особенность — уникальность, которая позволяет создавать расширяемые сервисы и приложения без...

Дата запрета программно в УТ 10, КОРП и УПП

Если Вам необходимо программно изменить Дату запрета по своим параметрам. Добавляем в модуле сеанса:  КоличествоДней = 5; Попытка ДатаУстановки = НачалоДня(ТекущаяДата()) -...

Сократить ФИО

Функция ФИО(Сотрудник) Экспорт Перем ПолноеИмя, Фамилия, ИмяОтчество, Имя, Отчество; Перем ПозицияПервогоПробела, ПозицияВторогоПробела; ПолноеИмя = Сотрудник.Наименование; ПозицияПервогоПробела =...

Как сравнивать типы значений

В 1С есть две функции, с помощью которых можно производить операции с типами. 

Контроль остатков в УТ 10.3

Меню: Сервис - Пользователи - Настройка дополнительных прав: - Разрешить превышение остатков на складе; - Разрешить превышение остатков организации.

Учет выплаченных и полученных дивидендов в "1С:Бухгалтерии 8" ред. 3.0

Компания может распределять прибыль между участниками (акционерами) ежеквартально, раз в полгода или раз в год. О том, как изменился с 1 января порядок исчисления налогов с дивидендов по акциям мы...

Тип документа 1с 8.x

 В ЗАПРОСЕ: ... ДокументСсылка ССЫЛКА Документ.Поступление ... В ТЕКСТЕ: Если ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.Поступление")  Тогда

Настройка журнала регистрации в 1С 8.2 (8.3)

Журнал регистрации 1С — специальный механизм платформы 1С версий 8.2 и 8.3, который позволяет фиксировать работу пользователей с системой. С помощью журнала можно узнать кто и когда изменял объекты...

Выгрузка / Загрузка данных посредством текстовых (TXT) файлов

Для работы с текстовыми документами существуют три типа данных – ТекстовыйДокумент, ЗаписьТекста и ЧтениеТекста. Разница двух подходов состоит в способе загрузки документа: ТекстовыйДокумент...

Создание документа Операция Бух программно

ДокОперация = Документы.ОперацияБух.СоздатьДокумент();

Печать ценников любого размера, УТ 10.3, БП 2.0

Обработка предназначена для редактирования ценников.

Запросы в 1С

 Примеры запросов в 1С 8 Как в запросе 1с8 установить условие проверки периода на конец дня? Как правильно обрабатывать значения NULL в запросе 1С8? Как вывести результат запроса в табличный...

Как определить программно, существует ли у документа 1С требуемый реквизит

Вопрос Как определить программно, существует ли у документа требуемый реквизит Ответ В типовых конфигурациях 1С для этой цели используется функция «ЕстьРеквизитДокумента» общего модуля...

Копирование регистра 1с

Порой для уже отрытых конфигураций необходимо создать идентичную копию регистра для работы с ней по новым правилам установленным заказчиком. Часто такую задачу делают для аналитических отделов...

тип документа в запросе 1с

ХозрасчетныйОбороты.Регистратор ССЫЛКА Документ.ПоступлениеТоваровУслуг

Количество субконто счета %s превышает максимально возможное!

Количество субконто счета %s превышает максимально возможное!

Ошибка выходит при обновлении или добавлении нового счета в план счетов. Заходим в Конфигурацию. Находим Планы счетов необходимый нам список. Меняем "Максимальное кличество счетов"  

Форма выбора с отбором

СтандартнаяОбработка = Ложь; ФормаВыбора = Справочники.Номенклатура.ПолучитьФормуВыбора(, Элемент);Если ЗначениеЗаполнено(Значение) Тогда ФормаВыбора.ЭлементыФормы.СправочникСписок.ТекущаяСтрока =...

Как редактировать записи в списке (8.2, 8.3) ?

ЭлементыФормы.СписокДоговорыПайщиков.СпособРедактирования = СпособРедактированияСписка.ВСписке;

8.Х. Как добавить записи в независимый регистр сведений?

Случай 1.МенеджерЗаписи = РегистрыСведений.ЗначенияСвойствОбъектов.СоздатьМенеджерЗаписи(); МенеджерЗаписи.Объект = ПолеВводаНоменклатура; МенеджерЗаписи.Свойство =...

Список значений в языке 1С 8.3, 8.2 (в примерах)

&НаКлиенте Процедура ВыполнитьКод(Команда)       /// Как создать список значений в 1с 8.3, 8.2   Список = Новый СписокЗначений;       /// Как добавить элемент в список значений в 1с...

Тип Структура в языке 1С 8.3, 8.2 (в примерах)

&НаКлиенте Процедура ВыполнитьКод(Команда)       /// Как создать структуру (способ 1) в 1с 8.3, 8.2  

Таблица значений в языке 1С 8.3, 8.2 (в примерах)

&НаСервере Процедура ВыполнитьКодНаСервере()       /// Как создать таблицу значений в 1с 8.3, 8.2  

Работа с файловой системой в языке 1С 8.3, 8.2 (в примерах)

&НаСервере Процедура ЧтениеИЗаписьФайловНаСервере()       /// Как записать произвольное значение в файл в 1с 8.3, 8.2  

Функция Формат в языке 1С 8.3, 8.2 (в примерах)

&НаКлиенте Процедура ВыполнитьКод(Команда)       /// Как указать общее число цифр в 1с 8.3, 8.2

Тип Соответствие в языке 1С 8.3, 8.2 (в примерах)

&НаКлиенте Процедура ВыполнитьКод(Команда)       /// Как создать соответствие в 1с 8.3, 8.2  

Как вычислить формулу в строке?

ЧисловойРезультат=Вычислить(СтроковыйПараметр)

Изменение записей независимого регистра сведений

Вариант 1. Менеджер = РегистрыСведений.МойРегистр.СоздатьМенеджерЗаписи(); Менеджер.Контрагент = ИмяКонтраг1; Менеджер.Прочитать(); Если Менеджер.Выбран() Тогда ...

Транзакция

Разработчик может и сам создать транзакцию. Для выполнения действий в транзакции необходимо в код активировать её: НачатьТранзакцию(); По окончании транзакции её необходимо...

1С отборы в форме выбора

Процедура СобытиеНачалоВыбора(Элемент, СтандартнаяОбработка) СтандартнаяОбработка = Ложь; ФормаВыбора = Документы.Документ1.ПолучитьФормуВыбора(,...

Обнаружена незавершенная операция обновления конфигурации бд

Восстановление при некорректном обновлении конфигурации. Обнаружена незавершенная операция обновления конфигурации бд

Перенос строки

Пример: НаборСтрок = "Первая строка"+Символы.ПС+ "Вторая строка"+Символы.ПС+ "Третья строка"; В конструкции Символы также содержаться: ВК (CR) — возврат...

Табличное поле в 1С 8.x

Табличное поле в 1С 8.x Как запретить пользователю изменять порядок следования колонок в табличном поле? Как запретить пользователю изменять любые настройки колонок табличного поля? Как...

  • Перенумерация документов

    Перенумерация документов

  • Нумерация документов

    Нумерация документов

  • Выгрузка/Загрузка Пользователей системы 1С

    Выгрузка/Загрузка Пользователей системы 1С

  • Замена ссылок в документах и справочниках

    Замена ссылок в документах и справочниках

  • Свертка базы данных в 1С

    Свертка базы данных в 1С

  • Счет-фактуры выданные для указанных документов Реализация товаров и услуг

    Счет-фактуры выданные для указанных документов Реализация товаров и услуг

  • Дата запрета изменения данных в 1с 8

    Дата запрета изменения данных в 1с 8

  • Ошибка "Нарушена целостность структуры конфигурации"

  • Удаление помеченных объектов

    Удаление помеченных объектов

  • Внутренняя ошибка компоненты dbeng8

  • Реестр в ФСС

    Реестр в ФСС

  • Изменения конфигурации заблокированы средствами распределенной ИБ

    Изменения конфигурации заблокированы средствами распределенной ИБ

  • Заполнение документа Реализация товаров и услуг по документу Заказ покупателя без учета остатков (УТ 10.3)

    Заполнение документа Реализация товаров и услуг по документу Заказ покупателя без учета остатков (УТ 10.3)

  • Расходы будущих периодов (страхование)

  • Уполномоченные лица в 1С:Бухгалтерии 8

  • Резервы по сомнительным долгам в 1С:Бухгалтерия 8

  • Распределение входящего НДС при совмещении режимов налогообложения в программе "1С:Бухгалтерия"

  • 1С: Предприниматель 8

    1С: Предприниматель 8

  • Чтение и запись XML в языке 1С 8.3, 8.2

  • Пустая дата в 1С

  • Как прибавить к дате день, месяц в 1С

  • Табличный документ, текстовый документ в 1С 8.x

  • Функция Формат в языке 1С 8.3, 8.2 (в примерах)

  • Работа с массивами в 1С 8.x

  • Обновление распределенной информационной базы (РИБ)

  • Построитель отчёта и таблица значений

  • Чтение данных с листа Excel

  • Функций по работе со строками

  • GUID, ГУИД, уникальный идентификатор

  • Дата запрета программно в УТ 10, КОРП и УПП

  • Сократить ФИО

  • Как сравнивать типы значений

  • Контроль остатков в УТ 10.3

  • Учет выплаченных и полученных дивидендов в "1С:Бухгалтерии 8" ред. 3.0

  • Тип документа 1с 8.x

  • Настройка журнала регистрации в 1С 8.2 (8.3)

  • Выгрузка / Загрузка данных посредством текстовых (TXT) файлов

  • Создание документа Операция Бух программно

  • Печать ценников любого размера, УТ 10.3, БП 2.0

  • Запросы в 1С

  • Как определить программно, существует ли у документа 1С требуемый реквизит

  • Как программно изменить проводку в Регистре Бухгалтерии?

  • Копирование регистра 1с

  • тип документа в запросе 1с

  • Количество субконто счета %s превышает максимально возможное!

    Количество субконто счета %s превышает максимально возможное!

  • Форма выбора с отбором

  • Как редактировать записи в списке (8.2, 8.3) ?

  • 8.Х. Как добавить записи в независимый регистр сведений?

  • Список значений в языке 1С 8.3, 8.2 (в примерах)

  • Тип Структура в языке 1С 8.3, 8.2 (в примерах)

  • Таблица значений в языке 1С 8.3, 8.2 (в примерах)

  • Работа с файловой системой в языке 1С 8.3, 8.2 (в примерах)

  • Функция Формат в языке 1С 8.3, 8.2 (в примерах)

  • Тип Соответствие в языке 1С 8.3, 8.2 (в примерах)

  • Как вычислить формулу в строке?

  • Изменение записей независимого регистра сведений

  • Транзакция

  • 1С отборы в форме выбора

  • Обнаружена незавершенная операция обновления конфигурации бд

  • Перенос строки

  • Табличное поле в 1С 8.x

Табличный документ, текстовый документ в 1С 8.x

 

Как вывести результат запроса в табличный документ?

    Запрос = Новый Запрос; 
    Запрос.Текст = "ВЫБРАТЬ 
    |	ОстаткиТоваровКомпанииОстатки.СкладКомпании КАК СкладКомпанииСсылка, 
    |	ОстаткиТоваровКомпанииОстатки.Номенклатура КАК НоменклатураСсылка, 
    |	СУММА(ОстаткиТоваровКомпанииОстатки.КоличествоОстаток) КАК Остаток, 
    |	ОстаткиТоваровКомпанииОстатки.Номенклатура.Представление КАК Номенклатура, 
    |	ОстаткиТоваровКомпанииОстатки.СкладКомпании.Представление КАК Склад 
    |ИЗ 
    |	РегистрНакопления.ОстаткиТоваровКомпании.Остатки(&Момент) КАК ОстаткиТоваровКомпанииОстатки 
    |СГРУППИРОВАТЬ ПО 
    |	ОстаткиТоваровКомпанииОстатки.СкладКомпанииСсылка, 
    |	ОстаткиТоваровКомпанииОстатки.НоменклатураСсылка 
    |ИТОГИ СУММА(Остаток) ПО 
    |	Общие, 
    |	Склад"; 

    Запрос.УстановитьПараметр("Момент", Неопределено); 

    Результат = Запрос.Выполнить(); 

    // Получить поле табличного документа, в которое будем выводить результат. 
    ТабДок = ЭлементыФормы.ПолеТабличногоДокумента; 

    // Очистить данные в табличном документе 
    // (возможно данные уже выводились ранее). 
    ТабДок.Очистить(); 

    Макет = ПолучитьМакет("Макет"); 

    // Получить именованные области из макета. 
    ОбластьОбщийИтог = Макет.ПолучитьОбласть("ОбщийИтог"); 
    ОбластьСклад = Макет.ПолучитьОбласть("Склад"); 
    ОбластьНоменклатура = Макет.ПолучитьОбласть("Номенклатура"); 

    // Получить выборку по первой итоговой группировке (первый уровень). 
    ВыборкаОбщийИтог = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам); 

    // Запись общего итога всегда одна, поэтому можно обойтись без организации цикла. 
    ВыборкаОбщийИтог.Следующий(); 

    // Произвести запись данных из полей выборки в именованные 
    // области с совпадающими именами. 
    ОбластьОбщийИтог.Параметры.Заполнить(ВыборкаОбщийИтог); 

    // Включить область с заполненными параметрами в табличный документ. 
    ТабДок.Вывести(ОбластьОбщийИтог); 

    // "От" записи первого уровня получить подчиненную выборку 
    // записей второго уровня (по итоговой группировке "Склад"). 
    ВыборкаПоСкладу = ВыборкаОбщийИтог.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам); 

    Пока ВыборкаПоСкладу.Следующий() Цикл 
        ОбластьСклад.Параметры.Заполнить(ВыборкаПоСкладу); 
        ТабДок.Вывести(ОбластьСклад); 

        // Получить подчиненную выборку, содержащую детальные записи. 
        ВыборкаПоНоменклатуре = ВыборкаПоСкладу.Выбрать(); 

        Пока ВыборкаПоНоменклатуре.Следующий() Цикл 
            ОбластьНоменклатура.Параметры.Заполнить(ВыборкаПоНоменклатуре); 
            ТабДок.Вывести(ОбластьНоменклатура); 
        КонецЦикла; 
    КонецЦикла;           
            

наверх


Как вывести данные в табличный документ с возможностью сворачивания и разворачивания данных по группировкам?

    // Перед выводом данных в табличный документ используется метод: 
    ТабДок.НачатьАвтогруппировкуСтрок();

    // Выести область с указанием уровня. 
    ТабДок.Вывести(ОбластьОбщийИтог, ВыборкаОбщийИтог.Уровень()); 

    // В конце работы с табличным документом необходимо выполнить 
    // следующий метод: 
    ТабДок.ЗакончитьАвтогруппировкуСтрок();          
            

наверх


Как при выводе данных в табличный документ свернуть все выводимые группировки?

    УровеньГруппировки = 1; //содержит индекс, с нуля 
    ТабДок.ЗакончитьАвтогруппировкуСтрок(); 
    ТабДок.ПоказатьУровеньГруппировокСтрок(УровеньГруппировки);          
            

наверх


Как при выводе данных в табличный документ произвольно определить состав свернутых и развернутых группировок?

    ТабДок.Вывести(ОбластьНоменклатура, ВыборкаПоНоменклатуре.Уровень(), , Ложь);          
            

наверх


Как выгрузить результат запроса с показом иерархии?

    Запрос = Новый Запрос; 
    Запрос.Текст = "ВЫБРАТЬ 
    |	ПродажиКомпанииОбороты.Номенклатура КАК Номенклатура, 
    |	ПродажиКомпанииОбороты.КоличествоОборот КАК КоличествоОборот 
    |ИЗ 
    |	РегистрНакопления.ПродажиКомпании.Обороты(&НачПериода, &КонПериода, , ) КАК ПродажиКомпанииОбороты 
    |ИТОГИ СУММА(КоличествоОборот) ПО 
    |	Номенклатура ИЕРАРХИЯ"; 

    Запрос.УстановитьПараметр("НачПериода", НачПериода); 
    Запрос.УстановитьПараметр("КонПериода", КонПериода); 

    Результат = Запрос.Выполнить();
     
    // Осуществить выгрузку с сохранением иерархии.
    ЭлементыФормы.ТП.Значение = Результат.Выгрузить(ОбходРезультатаЗапроса.ПоГруппировкам); 

    ЭлементыФормы.ТП.СоздатьКолонки();          
            

наверх


Где и как можно увидеть макет, автоматически генерируемый построителем отчета?

    ПостроительОтчета.Макет.Показать()          
            

наверх


Как из построителя отчета передать данные в сводную таблицу?

    ЭлементыФормы.ДокументРезультат.ВстроенныеТаблицы.СводнаяТаблица.ИсточникДанных = ПостроительОтчетаОтчет; 
    ЭлементыФормы.ДокументРезультат.ВстроенныеТаблицы.СводнаяТаблица.ОтображатьПоля = Истина;          
            

наверх


Отчет формируется построителем отчета. Как убрать одну из колонок, поместив ее данные в расшифровку другой?

    Процедура АлфавитныйПереченьКандидатовСРасшифровкой() 

        ПостроительОтчета = Новый ПостроительОтчета; 
        ПостроительОтчета.Текст ="ВЫБРАТЬ 
        |	РегистрацияСобеседованияКандидата.ФизЛицо КАК Кандидат, 
        |	РегистрацияСобеседованияКандидата.РезультатСобеседования КАК Результат, 
        |	РегистрацияСобеседованияКандидата.Ссылка 
        |ИЗ 
        |	Документ.РегистрацияСобеседованияКандидата КАК РегистрацияСобеседованияКандидата 
        |УПОРЯДОЧИТЬ ПО 
        |	РегистрацияСобеседованияКандидата.ФизЛицо.Наименование"; 

        ПостроительОтчета.Выполнить(); 

        Макет = ПостроительОтчета.Макет; 

        // Очистить области, связанные с ссылкой. 
        ТекущаяОбласть = Неопределено; 

        Пока Истина Цикл ТекущаяОбласть = Макет.НайтиТекст("Ссылка", ТекущаяОбласть, Макет.Область()); 

            Если ТекущаяОбласть = Неопределено Тогда 
                Прервать; 
            Иначе 
                ТекущаяОбласть.Очистить(Истина, Истина, Истина); 
            КонецЕсли; 
        КонецЦикла; 

        // Заполнить параметр расшифровки для областей, где параметр = "Результат". 
        ТекущаяОбласть = Неопределено; 
        Пока Истина Цикл ТекущаяОбласть = Макет.НайтиТекст("Результат", ТекущаяОбласть, Макет.Область()); 
            Если ТекущаяОбласть = Неопределено Тогда 
                Прервать; 
            Иначе 
                Если ТекущаяОбласть.Параметр = "Результат" Тогда 
                    ТекущаяОбласть.ПараметрРасшифровки = "Ссылка"; 
                КонецЕсли; 
            КонецЕсли; 
        КонецЦикла; 

        ПостроительОтчета.Макет = Макет; 
        ПостроительОтчета.Вывести(); 

    КонецПроцедуры           
            

наверх


Как сохранить настройки построителя отчета до следующего открытия формы отчета?

    СохранитьЗначение("НастройкаПостроителяДляОтчетаПродажи" + Метаданные().Имя, ПостроительОтчета.ПолучитьНастройки()); 

    // До установки настроек они ранее должны были быть заполнены 
    // по тексту запроса. 
    ПостроительОтчета.ЗаполнитьНастройки(); 

    // Установить настройки построителя отчета. 
    Настройка = ВосстановитьЗначение("НастройкаПостроителяДляОтчетаПродажи" + Метаданные().Имя); 
    Если Настройка <> Неопределено Тогда 
        ПостроительОтчета.УстановитьНастройки(Настройка); 
    КонецЕсли;          
            

наверх


Как организовать показ примечаний в формируемом табличном документе?

    Процедура Отчет(ДатаНач, ДатаКон) Экспорт 

        Запрос = Новый Запрос; 

        // Сбор данных. 
        Запрос.Текст = "ВЫБРАТЬ 
        |	Событие.Ответственный КАК Ответственный, 
        |	Событие.Дата, 
        |	Событие.ВидСобытия, 
        |	Событие.Контрагент, 
        |	Событие.СодержаниеСобытия, 
        |	Событие.ОписаниеСобытия 
        |ИЗ 
        |	Документ.Событие КАК Событие 
        |ГДЕ 
        |	Событие.Дата МЕЖДУ &ДатаНач И &ДатаКон И (Событие.Проведен) И Событие.СостояниеСобытия = &Завершено 
        |УПОРЯДОЧИТЬ ПО 
        |	Ответственный"; 

        Запрос.УстановитьПараметр("ДатаКон", ДатаКон); 
        Запрос.УстановитьПараметр("ДатаНач", ДатаНач); 
        Запрос.УстановитьПараметр("Завершено", Перечисления.СостоянияСобытий.Завершено); 

        Результат = Запрос.Выполнить(); 

        // Сформировать табличный документ. 
        Макет = ПолучитьМакет("Отчет"); 
        ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок"); 
        ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы"); 
        ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали"); 
        ТабДок = Новый ТабличныйДокумент; 
        ОбластьЗаголовок.Параметры.ДатаНач = ДатаНач; 
        ОбластьЗаголовок.Параметры.ДатаКон = ДатаКон; 
        ТабДок.Вывести(ОбластьЗаголовок); 
        ТабДок.Вывести(ОбластьШапкаТаблицы); 

        ВыборкаДетали = Результат.Выбрать(); 
        Пока ВыборкаДетали.Следующий() Цикл 
            ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетали); 
            ОбластьДетальныхЗаписей.Область("Описание").Примечание.Текст = ВыборкаДетали.СодержаниеСобытия; 
            ТабДок.Вывести(ОбластьДетальныхЗаписей); 
        КонецЦикла; 

        ТабДок.Показать(); 

    КонецПроцедуры          
            

наверх


Как обеспечить, чтобы при вводе на печать не печатались первая колонка и первая строка табличного документа "ДокументРезультат"?

    ДокументРезультат.ОбластьПечати = ДокументРезультат.Область(2, 2, ДокументРезультат.ВысотаТаблицы, ДокументРезультат.ШиринаТаблицы );          
            

наверх


Как обеспечить фиксацию верхней части табличного документа, генерируемого построителем отчета, по срезу шапки таблицы?

    ДокументРезультат.ФиксацияСверху = ПостроительОтчета.Макет.Области.ШапкаТаблицы.Низ;          
            

наверх


Табличный документ формируется построителем отчета. Как при печати табличного документа обеспечить вывод шапки таблицы на каждой странице?

    ОбластьШапки = ПостроительОтчета.Макет.Области.ШапкаТаблицы; 
    ДокументРезультат.ПовторятьПриПечатиСтроки = ДокументРезультат.Область(ОбластьШапки.Верх, , ОбластьШапки.Низ);          
            

наверх


Как при выводе на печать "длинного" документа указать в колонтитулах страниц номер документа, дату и номер страницы?

    ТабДокумент.ВерхнийКолонтитул.Выводить = Истина; 
    ТабДокумент.ВерхнийКолонтитул.НачальнаяСтраница = 2; 
    ТабДокумент.ВерхнийКолонтитул.ТекстСлева = Метаданные().Представление() + " № " + Номер; 
    ТабДокумент.ВерхнийКолонтитул.ТекстСправа = "[&НомерСтраницы]";          
            

наверх


Табличный документ формируется по макету, автоматически генерируемому построителем отчета. Как задать ориентацию страницы при печати?

    ПостроительОтчета.Вывести(ДокументРезультат); 
    ДокументРезультат.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;          
            

наверх


Табличный документ формируется построителем отчета. Как для всех выводимых числовых показателей установить вывод без дробной части?

    // Получить макет построителя отчета. 
    Макет = ПостроительОтчета.Макет; 

    // Сформатировать все области, где встречается слово "Стоимость". 
    ТекущаяОбласть = Неопределено; 

    Пока Истина Цикл 
        ТекущаяОбласть = Макет.НайтиТекст("Стоимость", ТекущаяОбласть, Макет.Область()); 

        Если ТекущаяОбласть = Неопределено Тогда 
            Прервать; 
        Иначе 
            Если ТекущаяОбласть.Параметр <> "" Тогда 
                ТекущаяОбласть.Формат = "ЧДЦ=0"; 
            КонецЕсли; 
        КонецЕсли; 
    КонецЦикла; 

    // Сформатировать все области, где встречается слово "Количество". 
    ТекущаяОбласть = Неопределено; 

    Пока Истина Цикл 
        ТекущаяОбласть = Макет.НайтиТекст("Количество", ТекущаяОбласть, Макет.Область()); 
        Если ТекущаяОбласть = Неопределено Тогда 
            Прервать; 
        Иначе 
            Если ТекущаяОбласть.Параметр <> "" Тогда 
                ТекущаяОбласть.Формат = "ЧДЦ=0"; 
            КонецЕсли; 
        КонецЕсли; 
    КонецЦикла; 

    // Назначить построителю измененный макет. 
    ПостроительОтчета.Макет = Макет; 

    // Вывести результат работы построителя отчета в табличный документ.          
            

наверх


Как для построителя отчета совместить назначение своего макета и применение одного из стандартных макетов оформления?

    ПостроительОтчета.МакетОформления = ПолучитьМакетОформления(СтандартноеОформление.Апельсин); 
    ПостроительОтчета.Макет = ПолучитьМакет("МакетЭтогоОтчета"); 
    ПостроительОтчета.ОформитьМакет();          
            

наверх


Как при получении данных из запроса обойти только итоговые записи?

    ТабДок = ЭлементыФормы.ПолеТабличногоДокумента; 
    ТабДок.Очистить(); 
    Макет = ПолучитьМакет("Отчет"); 
    Запрос = Новый Запрос; 
    Запрос.Текст = "ВЫБРАТЬ 
    |	ПродажиКомпанииОбороты.Номенклатура КАК Номенклатура, 
    |	ПродажиКомпанииОбороты.Номенклатура.Представление, 
    |	ПродажиКомпанииОбороты.КоличествоОборот КАК КоличествоОборот, 
    |	ПродажиКомпанииОбороты.СуммаПродажиОборот КАК СуммаПродажиОборот 
    |ИЗ 
    |	РегистрНакопления.ПродажиКомпании.Обороты(&НачПериода,&КонПериода) КАК ПродажиКомпанииОбороты 
    |ИТОГИ СУММА(КоличествоОборот), СУММА(СуммаПродажиОборот) ПО 
    |	ОБЩИЕ, 
    |	Номенклатура Иерархия"; 

    Запрос.УстановитьПараметр("&НачПериода", НачПериода); 
    Запрос.УстановитьПараметр("&КонПериода", КонецДня(КонПериода)); 

    Результат = Запрос.Выполнить(); 

    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок"); 
    ОбластьПодвал = Макет.ПолучитьОбласть("Подвал"); 
    ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы"); 
    ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы"); 
    ОбластьОбщийИтог = Макет.ПолучитьОбласть("ОбщиеИтоги"); 
    ОбластьНоменклатура = Макет.ПолучитьОбласть("Номенклатура"); 
    ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали"); 

    ТабДок.Вывести(ОбластьЗаголовок); 
    ТабДок.Вывести(ОбластьШапкаТаблицы); 

    // Обход по определенным в запросе итоговым группировкам. 
    ВыборкаОбщийИтог = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам); 

    // Запись общих итогов одна, поэтому нет необходимости в цикле. 
    ВыборкаОбщийИтог.Следующий(); 
    ОбластьОбщийИтог.Параметры.Заполнить(ВыборкаОбщийИтог); 
    ТабДок.Вывести(ОбластьОбщийИтог); 

    // Получить подчиненную выборку по итоговой группировке "номенклатура". 
    ВыборкаНоменклатура = ВыборкаОбщийИтог.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам); 
    Пока ВыборкаНоменклатура.Следующий() Цикл 
        ОбластьНоменклатура.Параметры.Заполнить(ВыборкаНоменклатура); 
        ТабДок.Вывести(ОбластьНоменклатура); 

        // Несмотря на то, что можем получить еще одну подчиненную 
        // выборку (по детальным записям) мы это не делаем, т.е. фактически 
        // при обходе пропускаем детальные записи. 

    КонецЦикла; 

    ТабДок.Вывести(ОбластьПодвалТаблицы); 
    ТабДок.Вывести(ОбластьПодвал);          
            

наверх


Как при получении данных из запроса обойти только иерархические итоговые записи?

    ВыборкаОбщийИтог = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией); 
    ВыборкаОбщийИтог.Следующий(); 
    ОбластьОбщийИтог.Параметры.Заполнить(ВыборкаОбщийИтог); 
    ТабДок.Вывести(ОбластьОбщийИтог); 
    ВыборкаНоменклатура = ВыборкаОбщийИтог.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкамСИерархией); 

    Пока ВыборкаНоменклатура.Следующий() Цикл 
        ОбластьНоменклатура.Параметры.Заполнить(ВыборкаНоменклатура); 	
        ТабДок.Вывести(ОбластьНоменклатура); 
    КонецЦикла;          
            

наверх


Как вывести картинку в табличный документ?

    ТабДок = Новый ТабличныйДокумент; 
    Макет = ОбработкаОбъект.ПолучитьМакет("Макет"); 
    ОбластьКартинки = Макет.ПолучитьОбласть("ОбластьСКартинкой"); 
    Картинка = Новый Картинка(ПутьККартинке); 

    // Элемент управления "Логотип" входит в коллекцию картинок области. 
    ОбластьКартинки.Рисунки.Логотип.Картинка = Картинка; 
    ТабДок.Вывести(ОбластьКартинки); 

    ТабДок.Показать();          
            

наверх


Как вывести картинку в табличный документ без изменения макета?

    Область = Макет.ПолучитьОбласть("Шапка"); 
    Рисунок = Область.Рисунки.Добавить(ТипРисункаТабличногоДокумента.Картинка); 
    Рисунок.Верх = 5; 
    Рисунок.Высота = 10; 
    Рисунок.Ширина = 10; 
    Рисунок.Лево = 5; 
    Рисунок.Картинка = Новый Картинка(ПутьККартинке); 
    Рисунок.РазмерКартинки = РазмерКартинки.РеальныйРазмер; 

    ТабДок.Вывести(Область);          
            

наверх


Как работать со сводной таблицей?

    Запрос = Новый Запрос; 
    Запрос.Текст = "ВЫБРАТЬ 
    |	ПродажиКомпанииОбороты.ДоговорВзаиморасчетовПокупателя.Владелец КАК ДоговорВзаиморасчетовПокупателяВладелец, 
    |	ПродажиКомпанииОбороты.Номенклатура КАК Номенклатура, 
    |	ПродажиКомпанииОбороты.ПодразделениеКомпании КАК ПодразделениеКомпании, 
    |	СУММА(ПродажиКомпанииОбороты.КоличествоОборот) КАК КоличествоОборот, 
    |	СУММА(ПродажиКомпанииОбороты.СуммаПродажиОборот) КАК СуммаПродажиОборот 
    |ИЗ 
    |	РегистрНакопления.ПродажиКомпании.Обороты(&НачПериода,&КонПериода) КАК ПродажиКомпанииОбороты 
    |СГРУППИРОВАТЬ ПО 
    |	ПродажиКомпанииОбороты.ДоговорВзаиморасчетовПокупателя.Владелец, 
    |	ПродажиКомпанииОбороты.Номенклатура, 
    |	ПродажиКомпанииОбороты.ПодразделениеКомпании 
    |ИТОГИ СУММА(КоличествоОборот), СУММА(СуммаПродажиОборот) ПО 
    |	ДоговорВзаиморасчетовПокупателяВладелец, 
    |	Номенклатура, 
    |	ПодразделениеКомпании"; 

    // На состав полей, которые могут быть размещены в измерениях, 
    // данных сводной таблицы влияет раздел "Итоги". 
    Запрос.УстановитьПараметр("НачПериода", НачПериода); 
    Запрос.УстановитьПараметр("КонПериода", КонПериода); 

    Результат = Запрос.Выполнить(); 

    Сводная = ЭлементыФормы.ПолеДокумента.ВстроенныеТаблицы.СводнаяТаблица1; 
    Сводная.ИсточникДанных = Результат;          
            

наверх


Как программно разместить данные в сводной таблице и оформить ее?

    Построитель = Новый ПостроительОтчета(); 
    Построитель.Текст = "ВЫБРАТЬ 
    |	ТоварыНаСкладахОстаткиИОбороты.Склад КАК Склад, 
    |	ТоварыНаСкладахОстаткиИОбороты.Склад.Представление, 
    |	ТоварыНаСкладахОстаткиИОбороты.Номенклатура КАК Номенклатура, 
    |	ТоварыНаСкладахОстаткиИОбороты.Номенклатура.Представление, 
    |	СУММА(ТоварыНаСкладахОстаткиИОбороты.КоличествоПриход) КАК КоличествоПриход, 
    |	СУММА(ТоварыНаСкладахОстаткиИОбороты.КоличествоОборот) КАК КоличествоОборот, 
    |	СУММА(ТоварыНаСкладахОстаткиИОбороты.КоличествоРасход) КАК КоличествоРасход 
    |ИЗ 
    |	РегистрНакопления.ТоварыНаСкладах.ОстаткиИОбороты КАК ТоварыНаСкладахОстаткиИОбороты 
    |СГРУППИРОВАТЬ ПО 
    |	ТоварыНаСкладахОстаткиИОбороты.Склад, 
    |	ТоварыНаСкладахОстаткиИОбороты.Номенклатура, 
    |	ТоварыНаСкладахОстаткиИОбороты.Склад.Представление, 
    |	ТоварыНаСкладахОстаткиИОбороты.Номенклатура.Представление 
    |ИТОГИ СУММА(КоличествоПриход), СУММА(КоличествоОборот), СУММА(КоличествоРасход) ПО 
    |	ОБЩИЕ, 
    |	Номенклатура ИЕРАРХИЯ, 
    |	Склад ИЕРАРХИЯ "; 

    Построитель.ЗаполнитьНастройки(); 
    Таблица = ЭлементыФормы.ПолеТабличногоДокумента1.ВстроенныеТаблицы.СводнаяТаблица1; 
    Таблица.МакетОформления = ПолучитьМакетОформления(СтандартноеОформление.Лед); 

    Таблица.ИсточникДанных = Построитель; 

    Таблица.Строки.Добавить("Номенклатура"); 
    Таблица.Колонки.Добавить("Склад"); 
    Таблица.Данные.Добавить("КоличествоПриход"); 

    Таблица.ОтображатьЛинии = ТипОтображенияЛинийСводнойТаблицы.Всегда;          
            

наверх


Как создать печатную форму посредством текстового шаблона?

    // Создать текстовый документ, в который будет выполняться вывод. 
    ТекстДок = Новый ТекстовыйДокумент; 

    // Получить макет.
    Макет = ПолучитьМакет("ЗаявкаНаПропуск"); 

    // Заголовок. 
    Область = Макет.ПолучитьОбласть("Заголовок"); 
    Область.Параметры.Дата = Дата; 
    Область.Параметры.ВремяНач = НачалоСобытия; 
    Область.Параметры.ВремяОконч = ОкончаниеСобытия; 
    ТекстДок.Вывести(Область); 

    // Состав. 
    Область = Макет.ПолучитьОбласть("Состав"); 

    Для Каждого ТекСтрокаСторонниеЛица Из СторонниеЛица Цикл 
        Область.Параметры.ФИО = Строка(ТекСтрокаСторонниеЛица.Лицо); 
        ТекстДок.Вывести(Область); 
    КонецЦикла; 

    // Подвал. 
    Область = Макет.ПолучитьОбласть("Подвал"); 
    Область.Параметры.Ответственный = Ответственный.Наименование; 
    ТекстДок.Вывести(Область); 

    // Открыть сформированный документ. 
    ТекстДок.Показать("Заявка на пропуска для События №" + Номер);          
            

наверх

 

АВТОР : http://pro1c.ru/

Похожие статьи:

Полезные обработки и отчеты

Полезные советы по БУ в 1С

JoomShaper Яндекс.Метрика Проверка PR и ТИЦ