Перенумерация документов

Перенумерация документов

 В своей практике я не раз сталкивался с ситуацией, когда пользователи 1С меняя нумерацию вручную убирали лидирующие нули и таким образом сбивали автоматическую нумерацию. Что делать? Как...

Нумерация документов

Нумерация документов

Достаточно отредактировать один раз номер. Например в 1С 8.2 Торговле. Описываем ситуацию. Отредактировали номер у документа, а следующий не записывается сообщая что номер не уникален или просто...

Выгрузка/Загрузка Пользователей системы 1С

Выгрузка/Загрузка Пользователей системы 1С

Внешняя обработка ВыгрузкаЗагрузкаПользователей.epf предназначена

Замена ссылок в документах и справочниках

Замена ссылок в документах и справочниках

Нередки случаи когда пользователи конфигураций 1С сталкиваются с проблемой возникновения дублей объектов информационной базы. Причины их возникновения мы рассматривать не будем,а рассмотрим как...

Свертка базы данных в 1С

Свертка базы данных в 1С

Свертка базы данных в 1С - это удаление данных, как правило документов, за прошлые отчётные периоды, по которым зафиксированы результаты хозяйственной деятельности, и данные не меняются.

Счет-фактуры выданные для указанных документов Реализация товаров и услуг

Счет-фактуры выданные для указанных документов Реализация товаров и услуг

Обработка автоматически создает документы “Счет-фактура выданный” для указанных документов “Реализация товаров и услуг” и проводит их.

Дата запрета изменения данных в 1с 8

Дата запрета изменения данных в 1с 8

Бухгалтерский и оперативный учет часто нуждается в блокировке данных за прошедший период. Особенно это актуально когда годовые отчеты сданы и документы все сверены. Период нужно "закрыть", чтобы...

Ошибка "Нарушена целостность структуры конфигурации"

Один из многих вариантов решения ошибки "Нарушена целостность структуры конфигурации".Если Вам довелось столкнуться с этой ошибкой обратитесь к специалисту 1С однозначно. Вариантов решения много,...

Удаление помеченных объектов

Удаление помеченных объектов

Модифицированная обработка «Удаление помеченных объектов»

Внутренняя ошибка компоненты dbeng8

Частая ошибка при активной работе всякого рода обработками. Поможет: Способ 1. В конфигураторе - Администрирование - Тестирование и исправление ошибок. Способ 2. Файл chdbfl.exe, который...

Реестр в ФСС

Реестр в ФСС

Данный обработка - внешний отчет, создан для конфигурации 1C "Зарплата и управление кадрами".  

Изменения конфигурации заблокированы средствами распределенной ИБ

Изменения конфигурации заблокированы средствами распределенной ИБ

Довольно редко, но встречается дополнительная блокировка информационной базы. При обновлении наталкивается что обновление и изменение поддежки не доступны, а рядом с замочком висит второй с...

Заполнение документа Реализация товаров и услуг по документу Заказ покупателя без учета остатков (УТ 10.3)

Заполнение документа Реализация товаров и услуг по документу Заказ покупателя без учета остатков (УТ 10.3)

В УТ 10.3 даже  при установленных флажках в Настройке дополнительных прав у пользователя Разрешить превышение остатка на складе и Разрешить превышение остатка товаров организации не заполняется...

Расходы будущих периодов (страхование)

Необходимо страхование гражданское отразить ввиде расходов будущих периодов, обязательно по разным подразделениям и статьям затрат (20 и 23, 25). Как это лучше реализовать в Бухгалтерии 2.0 Для...

Уполномоченные лица в 1С:Бухгалтерии 8

В 1С:Бухалтерии 8 появилась возможность в документах по реализации товаров и услуг и счетах-фактурах для автоматического вывода на печать указать ответственных лиц, подписывающих документы в полях...

Резервы по сомнительным долгам в 1С:Бухгалтерия 8

Внимание! В 1С:Бухгалтерия 8 ред. 2.0, начиная с релиза конфигурации 2.0.37.8, автоматизирован расчет резервов по сомнительным долгам в соответствии с п.70 Положения по ведению бухгалтерского учета...

Распределение входящего НДС при совмещении режимов налогообложения в программе "1С:Бухгалтерия"

При распределении НДС по косвенным расходам (совмещение ОСН и ЕНВД) в книгу покупок попадает не возмещаемая, а вся сумма входящего НДС и одновременно в книгу продаж невозмещаемая сумма. Есть две...

1С: Предприниматель 8

1С: Предприниматель 8

Программа "1С:Предприниматель 8" предназначена для индивидуальных предпринимателей (ИП). 1С Предприниматель - это готовое решение для ведения учета и составления отчетности. Программный продукт "1С...

Чтение и запись XML в языке 1С 8.3, 8.2

/// Как прочитать файл в формате XML через DOM /// в 1с 8.3, 8.2   &НаСервере Процедура ПрочитатьФайлXMLЧерезDOM(ПутьКФайлу)  

Пустая дата в 1С

В текстах модулей Если Дата = '00010101' Тогда Если Дата = '00010101000000' Тогда Если Дата = '0001-01-01' Тогда Если Дата = Дата(1, 1, 1) Тогда В запросах ГДЕ Дата =...

Как прибавить к дате день, месяц в 1С

СледующийДень = ТекущаяДата() + 60 * 60 * 24; ДобавитьМесяц(Дата(2005, 1, 31), 1); ДобавитьМесяц(Дата(2005, 2, 28), -1); КонецМесяца(ДобавитьМесяц(Дата(2005, 2, 28), -1)); Функция...

Работа с массивами в 1С 8.x

  Как создать массив? Как создать многомерный массив? Как добавить элементы в массив? Как определить размер массива? Как обратиться к элементу массива? Как перебрать элементы массива? Как...

Обновление распределенной информационной базы (РИБ)

Правильное обновление 1С при использовании обмена РИБ.

Построитель отчёта и таблица значений

Таблица значений была обработана построителем отчета 

Чтение данных с листа Excel

Функция ПрочитатьЛистExcel(ТЗ = Неопределено, ЛистЭксель = Неопределено,НомерПервойСтроки = 1, НомерПервойКолонки = 1, ВсегоСтрок = 0, ВсегоКолонок = 0) Экспорт

Функций по работе со строками

Здесь в краткой форме приведу функций по работе со строками:

GUID, ГУИД, уникальный идентификатор

«GUID (Globally Unique Identifier) — статистически уникальный 128-битный идентификатор. Его главная особенность — уникальность, которая позволяет создавать расширяемые сервисы и приложения без...

Дата запрета программно в УТ 10, КОРП и УПП

Если Вам необходимо программно изменить Дату запрета по своим параметрам. Добавляем в модуле сеанса:  КоличествоДней = 5; Попытка ДатаУстановки = НачалоДня(ТекущаяДата()) -...

Сократить ФИО

Функция ФИО(Сотрудник) Экспорт Перем ПолноеИмя, Фамилия, ИмяОтчество, Имя, Отчество; Перем ПозицияПервогоПробела, ПозицияВторогоПробела; ПолноеИмя = Сотрудник.Наименование; ПозицияПервогоПробела =...

Как сравнивать типы значений

В 1С есть две функции, с помощью которых можно производить операции с типами. 

Контроль остатков в УТ 10.3

Меню: Сервис - Пользователи - Настройка дополнительных прав: - Разрешить превышение остатков на складе; - Разрешить превышение остатков организации.

Учет выплаченных и полученных дивидендов в "1С:Бухгалтерии 8" ред. 3.0

Компания может распределять прибыль между участниками (акционерами) ежеквартально, раз в полгода или раз в год. О том, как изменился с 1 января порядок исчисления налогов с дивидендов по акциям мы...

Тип документа 1с 8.x

 В ЗАПРОСЕ: ... ДокументСсылка ССЫЛКА Документ.Поступление ... В ТЕКСТЕ: Если ТипЗнч(ДокументСсылка) = Тип("ДокументСсылка.Поступление")  Тогда

Настройка журнала регистрации в 1С 8.2 (8.3)

Журнал регистрации 1С — специальный механизм платформы 1С версий 8.2 и 8.3, который позволяет фиксировать работу пользователей с системой. С помощью журнала можно узнать кто и когда изменял объекты...

Выгрузка / Загрузка данных посредством текстовых (TXT) файлов

Для работы с текстовыми документами существуют три типа данных – ТекстовыйДокумент, ЗаписьТекста и ЧтениеТекста. Разница двух подходов состоит в способе загрузки документа: ТекстовыйДокумент...

Создание документа Операция Бух программно

ДокОперация = Документы.ОперацияБух.СоздатьДокумент();

Печать ценников любого размера, УТ 10.3, БП 2.0

Обработка предназначена для редактирования ценников.

Запросы в 1С

 Примеры запросов в 1С 8 Как в запросе 1с8 установить условие проверки периода на конец дня? Как правильно обрабатывать значения NULL в запросе 1С8? Как вывести результат запроса в табличный...

Как определить программно, существует ли у документа 1С требуемый реквизит

Вопрос Как определить программно, существует ли у документа требуемый реквизит Ответ В типовых конфигурациях 1С для этой цели используется функция «ЕстьРеквизитДокумента» общего модуля...

Копирование регистра 1с

Порой для уже отрытых конфигураций необходимо создать идентичную копию регистра для работы с ней по новым правилам установленным заказчиком. Часто такую задачу делают для аналитических отделов...

тип документа в запросе 1с

ХозрасчетныйОбороты.Регистратор ССЫЛКА Документ.ПоступлениеТоваровУслуг

Количество субконто счета %s превышает максимально возможное!

Количество субконто счета %s превышает максимально возможное!

Ошибка выходит при обновлении или добавлении нового счета в план счетов. Заходим в Конфигурацию. Находим Планы счетов необходимый нам список. Меняем "Максимальное кличество счетов"  

Форма выбора с отбором

СтандартнаяОбработка = Ложь; ФормаВыбора = Справочники.Номенклатура.ПолучитьФормуВыбора(, Элемент);Если ЗначениеЗаполнено(Значение) Тогда ФормаВыбора.ЭлементыФормы.СправочникСписок.ТекущаяСтрока =...

Как редактировать записи в списке (8.2, 8.3) ?

ЭлементыФормы.СписокДоговорыПайщиков.СпособРедактирования = СпособРедактированияСписка.ВСписке;

8.Х. Как добавить записи в независимый регистр сведений?

Случай 1.МенеджерЗаписи = РегистрыСведений.ЗначенияСвойствОбъектов.СоздатьМенеджерЗаписи(); МенеджерЗаписи.Объект = ПолеВводаНоменклатура; МенеджерЗаписи.Свойство =...

Список значений в языке 1С 8.3, 8.2 (в примерах)

&НаКлиенте Процедура ВыполнитьКод(Команда)       /// Как создать список значений в 1с 8.3, 8.2   Список = Новый СписокЗначений;       /// Как добавить элемент в список значений в 1с...

Тип Структура в языке 1С 8.3, 8.2 (в примерах)

&НаКлиенте Процедура ВыполнитьКод(Команда)       /// Как создать структуру (способ 1) в 1с 8.3, 8.2  

Таблица значений в языке 1С 8.3, 8.2 (в примерах)

&НаСервере Процедура ВыполнитьКодНаСервере()       /// Как создать таблицу значений в 1с 8.3, 8.2  

Работа с файловой системой в языке 1С 8.3, 8.2 (в примерах)

&НаСервере Процедура ЧтениеИЗаписьФайловНаСервере()       /// Как записать произвольное значение в файл в 1с 8.3, 8.2  

Функция Формат в языке 1С 8.3, 8.2 (в примерах)

&НаКлиенте Процедура ВыполнитьКод(Команда)       /// Как указать общее число цифр в 1с 8.3, 8.2

Тип Соответствие в языке 1С 8.3, 8.2 (в примерах)

&НаКлиенте Процедура ВыполнитьКод(Команда)       /// Как создать соответствие в 1с 8.3, 8.2  

Как вычислить формулу в строке?

ЧисловойРезультат=Вычислить(СтроковыйПараметр)

Изменение записей независимого регистра сведений

Вариант 1. Менеджер = РегистрыСведений.МойРегистр.СоздатьМенеджерЗаписи(); Менеджер.Контрагент = ИмяКонтраг1; Менеджер.Прочитать(); Если Менеджер.Выбран() Тогда ...

Транзакция

Разработчик может и сам создать транзакцию. Для выполнения действий в транзакции необходимо в код активировать её: НачатьТранзакцию(); По окончании транзакции её необходимо...

1С отборы в форме выбора

Процедура СобытиеНачалоВыбора(Элемент, СтандартнаяОбработка) СтандартнаяОбработка = Ложь; ФормаВыбора = Документы.Документ1.ПолучитьФормуВыбора(,...

Обнаружена незавершенная операция обновления конфигурации бд

Восстановление при некорректном обновлении конфигурации. Обнаружена незавершенная операция обновления конфигурации бд

Перенос строки

Пример: НаборСтрок = "Первая строка"+Символы.ПС+ "Вторая строка"+Символы.ПС+ "Третья строка"; В конструкции Символы также содержаться: ВК (CR) — возврат...

Табличное поле в 1С 8.x

Табличное поле в 1С 8.x Как запретить пользователю изменять порядок следования колонок в табличном поле? Как запретить пользователю изменять любые настройки колонок табличного поля? Как...

  • Перенумерация документов

    Перенумерация документов

  • Нумерация документов

    Нумерация документов

  • Выгрузка/Загрузка Пользователей системы 1С

    Выгрузка/Загрузка Пользователей системы 1С

  • Замена ссылок в документах и справочниках

    Замена ссылок в документах и справочниках

  • Свертка базы данных в 1С

    Свертка базы данных в 1С

  • Счет-фактуры выданные для указанных документов Реализация товаров и услуг

    Счет-фактуры выданные для указанных документов Реализация товаров и услуг

  • Дата запрета изменения данных в 1с 8

    Дата запрета изменения данных в 1с 8

  • Ошибка "Нарушена целостность структуры конфигурации"

  • Удаление помеченных объектов

    Удаление помеченных объектов

  • Внутренняя ошибка компоненты dbeng8

  • Реестр в ФСС

    Реестр в ФСС

  • Изменения конфигурации заблокированы средствами распределенной ИБ

    Изменения конфигурации заблокированы средствами распределенной ИБ

  • Заполнение документа Реализация товаров и услуг по документу Заказ покупателя без учета остатков (УТ 10.3)

    Заполнение документа Реализация товаров и услуг по документу Заказ покупателя без учета остатков (УТ 10.3)

  • Расходы будущих периодов (страхование)

  • Уполномоченные лица в 1С:Бухгалтерии 8

  • Резервы по сомнительным долгам в 1С:Бухгалтерия 8

  • Распределение входящего НДС при совмещении режимов налогообложения в программе "1С:Бухгалтерия"

  • 1С: Предприниматель 8

    1С: Предприниматель 8

  • Чтение и запись XML в языке 1С 8.3, 8.2

  • Пустая дата в 1С

  • Как прибавить к дате день, месяц в 1С

  • Табличный документ, текстовый документ в 1С 8.x

  • Функция Формат в языке 1С 8.3, 8.2 (в примерах)

  • Работа с массивами в 1С 8.x

  • Обновление распределенной информационной базы (РИБ)

  • Построитель отчёта и таблица значений

  • Чтение данных с листа Excel

  • Функций по работе со строками

  • GUID, ГУИД, уникальный идентификатор

  • Дата запрета программно в УТ 10, КОРП и УПП

  • Сократить ФИО

  • Как сравнивать типы значений

  • Контроль остатков в УТ 10.3

  • Учет выплаченных и полученных дивидендов в "1С:Бухгалтерии 8" ред. 3.0

  • Тип документа 1с 8.x

  • Настройка журнала регистрации в 1С 8.2 (8.3)

  • Выгрузка / Загрузка данных посредством текстовых (TXT) файлов

  • Создание документа Операция Бух программно

  • Печать ценников любого размера, УТ 10.3, БП 2.0

  • Запросы в 1С

  • Как определить программно, существует ли у документа 1С требуемый реквизит

  • Как программно изменить проводку в Регистре Бухгалтерии?

  • Копирование регистра 1с

  • тип документа в запросе 1с

  • Количество субконто счета %s превышает максимально возможное!

    Количество субконто счета %s превышает максимально возможное!

  • Форма выбора с отбором

  • Как редактировать записи в списке (8.2, 8.3) ?

  • 8.Х. Как добавить записи в независимый регистр сведений?

  • Список значений в языке 1С 8.3, 8.2 (в примерах)

  • Тип Структура в языке 1С 8.3, 8.2 (в примерах)

  • Таблица значений в языке 1С 8.3, 8.2 (в примерах)

  • Работа с файловой системой в языке 1С 8.3, 8.2 (в примерах)

  • Функция Формат в языке 1С 8.3, 8.2 (в примерах)

  • Тип Соответствие в языке 1С 8.3, 8.2 (в примерах)

  • Как вычислить формулу в строке?

  • Изменение записей независимого регистра сведений

  • Транзакция

  • 1С отборы в форме выбора

  • Обнаружена незавершенная операция обновления конфигурации бд

  • Перенос строки

  • Табличное поле в 1С 8.x

Работа с массивами в 1С 8.x

 


Как создать массив?

    СозданныйМассив = Новый Массив();
    СозданныйМассив = Новый Массив(10);         
            

наверх


Как создать многомерный массив?

    ДвумерныйМассив = Новый Массив(2, 8); 

    ДвумерныйМассив = Новый Массив; 
    МассивВторогоПорядка = Новый Массив(8); 
    ДвумерныйМассив.Добавить(МассивВторогоПорядка); 
    ДвумерныйМассив.Добавить(МассивВторогоПорядка); 

    Значение = ДвумерныйМассив[2][5];
    Значение = ДвумерныйМассив.Получить(2).Получить(5);          
            

наверх


Как добавить элементы в массив?

    НашМассив.Добавить(НовоеЗначение);

    Массив = Новый Массив; 
    Массив.Вставить(5, "ООО ""Лабан""");          
            

наверх


Как определить размер массива?

    Размер = НашМассив.Количество();          
            

наверх


Как обратиться к элементу массива?

    ПервоеЗначение = НашМассив[0]; 
    НашМассив[9] = ДесятоеЗначение; 
    ПервоеЗначение = НашМассив.Получить(0); 
    НашМассив.Установить(9, ДесятоеЗначение);          
            

наверх


Как перебрать элементы массива?

    Для Каждого ЭлементМассива Из МассивЭлементов Цикл 
        Если ТипЗнч(ЭлементМассива) = Тип("Число") Тогда 
            Сообщить(ЭлементМассива); 
        КонецЕсли; 
    КонецЦикла; 

    Для Сч = 0 по МассивЭлементов.ВГраница() Цикл 
        Если ТипЗнч(МассивЭлементов[Сч]) = Тип("Число") Тогда 
            МассивЭлементов[Сч] = 0; 
        КонецЕсли; 
    КонецЦикла;          
            

наверх


Как удалить элемент массива?

    МассивЭлементов.Удалить(0); 

    Индекс = МассивЭлементов.ВГраница();
    Пока Индекс >= 0 Цикл 
       Если ТипЗнч(МассивЭлементов[Индекс]) = Тип("Число") Тогда 
          МассивЭлементов.Удалить(Индекс); 
       КонецЕсли; 
       Индекс = Индекс - 1; 
    КонецЦикла;           
            

наверх


Как удалить все элементы массива?

    Массив.Очистить();          
            

наверх


Как удалить повторяющиеся элементы массива?

    Процедура УдалитьПовторяющиесяЭлементы(Массив) 

        ТекущийИндекс = 0; 
        ВсегоЭлементов = Массив.Количество(); 
        Пока ТекущийИндекс < ВсегоЭлементов Цикл 
            Индекс2 = ТекущийИндекс + 1; 
            Пока Индекс2 < ВсегоЭлементов Цикл 
                Если Массив[Индекс2] = Массив[ТекущийИндекс] Тогда 
                    Массив.Удалить(Индекс2); 
                    ВсегоЭлементов = ВсегоЭлементов - 1; 
                Иначе 
                    Индекс2 = Индекс2 + 1; 
                КонецЕсли; 
            КонецЦикла; 
            ТекущийИндекс = ТекущийИндекс + 1; 
        КонецЦикла; 

    КонецПроцедуры           
            

наверх


Как скопировать массив?

    Функция СкопироватьМассив(ИсходныйМассив) 
        
        МассивКопия = Новый Массив; 
        Для Каждого Элемент Из ИсходныйМассив Цикл 
            МассивКопия.Добавить(Элемент); 
        КонецЦикла; 
        
        Возврат МассивКопия; 

    КонецФункции          
            

наверх


Как проверить, что два массива идентичны?

    Функция ПроверитьИдентичностьМассивов(ПервыйМассив, ВторойМассив) 
        
        НаибольшийИндекс = ПервыйМассив.ВГраница(); 
        Если НаибольшийИндекс > ВторойМассив.ВГраница () Тогда 
            Возврат Ложь; 
        КонецЕсли; 
        
        Для Счетчик = 0 По НаибольшийИндекс Цикл 
            Если ПервыйМассив[Счетчик] <> ВторойМассив[Счетчик] Тогда 
            Возврат Ложь; 
            КонецЕсли; 
        КонецЦикла; 
        
        Возврат Истина; 
        
    КонецФункции          
            

наверх


В массив выгружены данные, содержащие наименования контрагентов. Как их отсортировать?

    СписокЗначений = Новый СписокЗначений; 
    СписокЗначений.ЗагрузитьЗначения(МассивНаименований); 
    СписокЗначений.СортироватьПоЗначению(); 
    МассивНаименований = СписокЗначений.ВыгрузитьЗначения(); 

    СписокЗначений.СортироватьПоЗначению(НаправлениеСортировки.Убыв);          
            

наверх


Есть массив, в который выгружены значения типа СправочникСсылка.Номенклатура. Как удалить все пустые значения массива?

    Процедура УдалитьПустыеЭлементы(МассивНоменклатуры) 

        Счетчик = 0; 
        КоличествоЭлементов = МассивНоменклатуры.Количество(); 
        Пока Счетчик < КоличествоЭлементов Цикл 
            Если МассивНоменклатуры [Счетчик].Пустая() Тогда 
                МассивНоменклатуры.Удалить(Счетчик); 
                КоличествоЭлементов = КоличествоЭлементов - 1; 
            Иначе 
                Счетчик = Счетчик + 1; 
            КонецЕсли; 
        КонецЦикла; 

    КонецПроцедуры          
            

наверх


Как получить массив номенклатурных позиций, использованных в табличных частях "Номенклатура" и "Тара" накладной?

    МассивНоменклатуры = СсылкаНаДокумент.Номенклатура.ВыгрузитьКолонку("Номенклатура"); 
    МассивНоменклатурыТара = СсылкаНаДокумент.ВозвратнаяТара.ВыгрузитьКолонку("Номенклатура"); 
    Для Каждого ЭлементМассиваТара Из МассивНоменклатурыТара Цикл 
        МассивНоменклатуры.Добавить(ЭлементМассиваТара); 
    КонецЦикла;           
            

наверх


Есть две таблицы значений. Как получить массив совпадающих имен колонок?

    МассивСовпадающихКолонок = Новый Массив(); 
    Для Каждого Колонка Из ТаблицаПриемник.Колонки Цикл 
        ИмяКолонкиПриемника = Колонка.Имя; 
        Если ТаблицаИсточник.Колонки.Найти(ИмяКолонкиПриемника) <> Неопределено Тогда 
            МассивСовпадающихКолонок.Добавить(ИмяКолонкиПриемника); 
        КонецЕсли; 
    КонецЦикла;           
            

наверх


Как в запросе сделать отбор по нескольким вариантам заполнения реквизита типа "ПеречислениеСсылка"?

    Запрос = Новый Запрос; 
    Запрос.Текст = "
    |ВЫБРАТЬ 
    |	ОтпускаОрганизацииРаботникиОрганизации.ФизЛицо, 
    |	ОтпускаОрганизацииРаботникиОрганизации.ДатаНачала, 
    |	ОтпускаОрганизацииРаботникиОрганизации.ДатаОкончания 
    |ИЗ 
    |	Документ.ОтпускаОрганизации.РаботникиОрганизации КАК ОтпускаОрганизацииРаботникиОрганизации 
    |ГДЕ 
    |	ОтпускаОрганизацииРаботникиОрганизации.ПричинаОтсутствия В (&МассивПричин)"; 

    МассивПричин = Новый Массив; 
    МассивПричин.Добавить(Перечисления.ПричиныОтсутствияНаРаботеВОрганизации.ОтпускБезСохраненияЗарплаты); 
    МассивПричин.Добавить(Перечисления.ПричиныОтсутствияНаРаботеВОрганизации.ОтпускУчебный); 

    Запрос.УстановитьПараметр("МассивПричин", МассивПричин);           
            

наверх


Как из регистра сведений "РасчетчикиЗарплатыОрганизации" получить в виде массива всех расчетчиков зарплаты определенного подразделения организации?

    Функция ПолучитьМассивРасчетчиков(Подразделение) 

        НаборЗаписей = РегистрыСведений.РасчетчикиЗарплатыОрганизации.СоздатьНаборЗаписей(); 
        НаборЗаписей.Отбор.ПодразделениеОрганизации.Установить(Подразделение); 
        НаборЗаписей.Прочитать(); 
        МассивРасчетчиков = НаборЗаписей.ВыгрузитьКолонку("Пользователь"); 
        
        Возврат МассивРасчетчиков; 

    КонецФункции 

    Функция ПолучитьМассивРасчетчиков(Подразделение) 

        Запрос = Новый Запрос; 
        Запрос.Текст = "
        |ВЫБРАТЬ 
        |	РасчетчикиЗарплатыОрганизации.Пользователь КАК Расчетчик 
        |ИЗ 
        |	РегистрСведений.РасчетчикиЗарплатыОрганизации КАК РасчетчикиЗарплатыОрганизации 
        |ГДЕ 
        |	РасчетчикиЗарплатыОрганизации.ПодразделениеОрганизации = &Подразделение"; 

        Запрос.УстановитьПараметр("Подразделение", Подразделение); 

        Результат = Запрос.Выполнить(); 
        Выборка = Результат.Выбрать(); 

        МассивРасчетчиков = Новый Массив; 
        Пока Выборка.Следующий() Цикл 
            МассивРасчетчиков.Добавить(Выборка.Расчетчик); 
        КонецЦикла; 

        Возврат МассивРасчетчиков; 

    КонецФункции          
            

наверх

Похожие статьи:

Полезные обработки и отчеты

Полезные советы по БУ в 1С

JoomShaper Яндекс.Метрика Проверка PR и ТИЦ